summaryrefslogtreecommitdiff
path: root/dev-python/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/termcolor
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest2
-rw-r--r--dev-python/termcolor/termcolor-2.2.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 76a5fedc81d5..f9e374e91d86 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,3 +1,5 @@
DIST python-termcolor-2.1.1.tar.gz 10831 BLAKE2B 0c5537f81234411ddb117266e45ac7ec8ea0af0f62e08883f4893aec21d83d03534200d1ad1633bed4c57cfd7a83305aaff5af7b0574d948854b7762c9e631f4 SHA512 f652d8ce07e192820c57d62fe76495e81e859a709e61b8a1418985da51a92ce8b71865b362d10331d40a914497fa2bf81e95c924c88ae281663a430ef065ca18
+DIST python-termcolor-2.2.0.tar.gz 11340 BLAKE2B c1a7119bf4b6a137784e1b395d65ce2222e78c3747d1198b0c3407a15b02aa2f0343a12ac067696f19e94b4add0f8968164223f77cc79ffb703601003b8ce8fd SHA512 24a686c6589a56d2ae9ef9a974dc2308d23e9dcbc586df2c2e6ce938f4a6d85bcd20e4ecafcdee8b5b859917defd2965804e10ef761ce7929dc44826f0fca402
EBUILD termcolor-2.1.1.ebuild 722 BLAKE2B 48c211d3a182b59902b1f02e3dd3a1299575fa301d8f70f78965b0e71c13618c78f0fed529206d2eed29e9f9d3fffbf0cd1e1a949f80d3148d1331876ebd662a SHA512 e46aa7860aa4313dc4cd5d62806a16631e70af477fe89522ab7a8ff3a636744ef9a38d19ea0c271c8c919167fff4cd7e397a6dda06638f001c704bc23d3e7274
+EBUILD termcolor-2.2.0.ebuild 730 BLAKE2B 64c5225a92cb6f486c6eac3a53537ddcd81ffc814c5c969846f643306df283855b0e2ce5abc976cbeb03de8dd9d517bd3c571f6f7ecfb9671c6661d1c6fada56 SHA512 cd75e9c9d748c4ae469c39f1b4e613ec8ec5c62f3eb7fd0c760b53ef41d545ad66e6877ab02e77ddac9ef1b1c436c45bcd4e5bcb07b2fc37e11a835e4877e3c1
MISC metadata.xml 530 BLAKE2B 6a8fc517eae6f2bbc099ba4e24cfdd48e6baf092baaef4921e9665521eec54c741a7cae9bb4d03cadedb845f5d5cd631c46544709c3efc4d4103408a57f35c26 SHA512 c2bf2f0aa44c39d4c9b2865c7f0a8abea0956bbcaed38485de60b7baedcda0df2f71d34e4a6bb5355eccbaa8dcc21e8c1b47d948d968668e3e55c3e8d7f3efa4
diff --git a/dev-python/termcolor/termcolor-2.2.0.ebuild b/dev-python/termcolor/termcolor-2.2.0.ebuild
new file mode 100644
index 000000000000..987b49d298af
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> python-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest