summaryrefslogtreecommitdiff
path: root/dev-python/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 19:04:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 19:04:59 +0000
commit77b9f0d5906f0bd9ddf010abe155218c6629738a (patch)
tree8cea5001e36d78aea62dd100ba74ee77906b69e6 /dev-python/termcolor
parentf5a622ba784bb66ee85eb669a821801c5e135ed8 (diff)
gentoo auto-resync : 21:11:2022 - 19:04:59
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest2
-rw-r--r--dev-python/termcolor/termcolor-2.1.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 954e7f5d5c43..bcc9d99d6152 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,5 +1,7 @@
DIST python-termcolor-2.1.0.tar.gz 10665 BLAKE2B f3f08d3a490d8e20e5da0b7e639fa0ff780fcdf9c41bce2b962b157437b6880cccace05668e71808598d51eb00a043c9dad4800aaa1f734a931c0a01378ad8f7 SHA512 9dd1b8f1d137fc66d77f26913297a6c82eb25b3fd7ae1c5e639cd023eff02f155363ed5b731ff36bcb4281b7678d8e508fb8430ae0f89fa02b9c219e03f99e8f
+DIST python-termcolor-2.1.1.tar.gz 10831 BLAKE2B 0c5537f81234411ddb117266e45ac7ec8ea0af0f62e08883f4893aec21d83d03534200d1ad1633bed4c57cfd7a83305aaff5af7b0574d948854b7762c9e631f4 SHA512 f652d8ce07e192820c57d62fe76495e81e859a709e61b8a1418985da51a92ce8b71865b362d10331d40a914497fa2bf81e95c924c88ae281663a430ef065ca18
DIST termcolor-2.0.1.tar.gz 9693 BLAKE2B 68592597da70957bd3f03a9a76e546ab17f7c437d00aca53325a617b02c5600679c9912c0ca8d9f7ade03a042cd657e86b1e12a588ec1eeafdfa57f3f5f16372 SHA512 e49f05e587fb420aa373d1644d66e4832a701385fc1da85470fa0d811770f73908ca139e1c1e9cb968cbc74285b038833f371854edc6e20bc22059b31ef1a1ed
EBUILD termcolor-2.0.1.ebuild 643 BLAKE2B ea79175a88c94c4b9530e43b04b4e5da9ab22db6e00718163eed343d39a4f156736414f20fa6de77e957b96299dd2ac2d9cf923d1e75d41ae60e0fdb6ee9fff8 SHA512 bce8238eabe15a6ee0dcc328ccc45799e1a0ac510d0cd8c5c532d56302a95b045743698d2381f2aa7d6068641db3d3e030ca6e5d3a00010516b5155b5d28c667
EBUILD termcolor-2.1.0.ebuild 730 BLAKE2B b549229497c872ceb8295b95ec1245806918e9dbea2b999922407584f574ab71203c90bf10ab4b082cdc0eef03452683cbb6ba10fbc89bcad5d609860d901847 SHA512 0d52e6f5a90cf759dbbc667dc6caceb3a518f53c21168b6a2819d9cb619482fbe3507247dfe8a26d2f226e58972f0ddd5c6d475b5203be4f1c40abaa63028797
+EBUILD termcolor-2.1.1.ebuild 730 BLAKE2B b549229497c872ceb8295b95ec1245806918e9dbea2b999922407584f574ab71203c90bf10ab4b082cdc0eef03452683cbb6ba10fbc89bcad5d609860d901847 SHA512 0d52e6f5a90cf759dbbc667dc6caceb3a518f53c21168b6a2819d9cb619482fbe3507247dfe8a26d2f226e58972f0ddd5c6d475b5203be4f1c40abaa63028797
MISC metadata.xml 530 BLAKE2B 6a8fc517eae6f2bbc099ba4e24cfdd48e6baf092baaef4921e9665521eec54c741a7cae9bb4d03cadedb845f5d5cd631c46544709c3efc4d4103408a57f35c26 SHA512 c2bf2f0aa44c39d4c9b2865c7f0a8abea0956bbcaed38485de60b7baedcda0df2f71d34e4a6bb5355eccbaa8dcc21e8c1b47d948d968668e3e55c3e8d7f3efa4
diff --git a/dev-python/termcolor/termcolor-2.1.1.ebuild b/dev-python/termcolor/termcolor-2.1.1.ebuild
new file mode 100644
index 000000000000..d29179a49c72
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> python-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest