summaryrefslogtreecommitdiff
path: root/dev-python/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /dev-python/termcolor
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest2
-rw-r--r--dev-python/termcolor/termcolor-2.4.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 3b87089ccfbb..ae3ae2b60e9a 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,3 +1,5 @@
DIST termcolor-2.3.0.py.tar.gz 12163 BLAKE2B a500cc13b0a7d43c32981f82408491c6fd30e489c1729bdbecae6e13e9deefe4a54944da56a241bc5c5f5411abfc2671dab8bc3ae23adf907f7eba617223f308 SHA512 0ccfd9320235215b85ddbf099399aaa325dd7176be7a39225377a81c372f9733105dcfe4a9e577cdca451be1f9b5538a071fc511bccd226fe0c4cbecb536bbf3
+DIST termcolor-2.4.0.py.tar.gz 12664 BLAKE2B e5cf8f3ce1d27ffc0128cd9c1e38323e1e579a7a4017254a1d03c5f5baf0fa897522134ea68929c2e492b933fe8a6c3d79b55cb674fa3af134445581d870bf85 SHA512 e715940ccc8863baae020345cabc8fc90b5bbbd5ef4b384de96920a90d97508cee6f863aa39a2c08971e58f45cf85ec73c0659715f54072bbc57612681138355
EBUILD termcolor-2.3.0.ebuild 700 BLAKE2B 42db3063868893d11604b7d0e51671c8103f250294e8bbba51eb5c5bd05e8ab85e15f1b234a0ccf37c1f975104ce59e9852c591e583cfbfd3b3cb5fced80c644 SHA512 cabe7b28534e5662d2aad2180a6b0434d400a2d2f4365c95c3bb7a23360a116643ecba373d02fecac783a2e12514389985c1ef92cfddad0b2f4097370ef1caff
+EBUILD termcolor-2.4.0.ebuild 708 BLAKE2B 73bcb4dd84ddd23988a905352da49bcb1701f9875fdc63a46c519ea63f0cc27b26c54fc78426cbabfae73d1cd399fb1d55cd56cef8bf5b25426c1ed4d164475d SHA512 160e5f3dc3558bb4a52d8803e1978c6769d5ce0dbf2823b665bf5bca60228d6a0be9915554f0f8421dcbf75e29effacba816aa8e91578f791048b429760c3334
MISC metadata.xml 530 BLAKE2B 6a8fc517eae6f2bbc099ba4e24cfdd48e6baf092baaef4921e9665521eec54c741a7cae9bb4d03cadedb845f5d5cd631c46544709c3efc4d4103408a57f35c26 SHA512 c2bf2f0aa44c39d4c9b2865c7f0a8abea0956bbcaed38485de60b7baedcda0df2f71d34e4a6bb5355eccbaa8dcc21e8c1b47d948d968668e3e55c3e8d7f3efa4
diff --git a/dev-python/termcolor/termcolor-2.4.0.ebuild b/dev-python/termcolor/termcolor-2.4.0.ebuild
new file mode 100644
index 000000000000..7ace1b1d05f7
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="$(pypi_sdist_url) -> ${P}.py.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest