summaryrefslogtreecommitdiff
path: root/dev-python/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
commit0ed86cb810f23bc360b9f8b955903db4e6595244 (patch)
tree7eb8d293be0f1777854714006cde9d7839450a2e /dev-python/termcolor
parentb46286b28de30f0898fa7888ae7dee09db822088 (diff)
gentoo auto-resync : 24:04:2023 - 12:10:01
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest2
-rw-r--r--dev-python/termcolor/termcolor-2.3.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index b1bfef24d490..f4476df93f7b 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,3 +1,5 @@
DIST python-termcolor-2.2.0.tar.gz 11340 BLAKE2B c1a7119bf4b6a137784e1b395d65ce2222e78c3747d1198b0c3407a15b02aa2f0343a12ac067696f19e94b4add0f8968164223f77cc79ffb703601003b8ce8fd SHA512 24a686c6589a56d2ae9ef9a974dc2308d23e9dcbc586df2c2e6ce938f4a6d85bcd20e4ecafcdee8b5b859917defd2965804e10ef761ce7929dc44826f0fca402
+DIST termcolor-2.3.0.py.tar.gz 12163 BLAKE2B a500cc13b0a7d43c32981f82408491c6fd30e489c1729bdbecae6e13e9deefe4a54944da56a241bc5c5f5411abfc2671dab8bc3ae23adf907f7eba617223f308 SHA512 0ccfd9320235215b85ddbf099399aaa325dd7176be7a39225377a81c372f9733105dcfe4a9e577cdca451be1f9b5538a071fc511bccd226fe0c4cbecb536bbf3
EBUILD termcolor-2.2.0.ebuild 703 BLAKE2B 81bb72d7291b80ef8e6e949fafd4b54f845995468cb5e8d1e96f0131f5e80fac03b63c880303b21f5b2fa9ef4afed0094d4a81e153a011ca7183aabc9da1ade8 SHA512 52107612734db7839a7cf1a883e3850ab6e4df026853ce86eda6219967f9e02aefe559b962ddb9b25f7878aaad011a3a3afb6a522bcf4428c5da379370384532
+EBUILD termcolor-2.3.0.ebuild 707 BLAKE2B a957172a32dfe5ccee5a523fe783928c9dfa43f3730669287ff243f1d730a8ff493bad1b3b9db33635415783779d52c4d96ab53575b43ef1144597ac93c83ae5 SHA512 ea34d5a7edb1f662e44a9decc7661273ed9dee49d60311d9da407590648e6a7e25bb44adc870111ff935db3ed171a3eb65821b795c22dfef8417705dbdd58a01
MISC metadata.xml 530 BLAKE2B 6a8fc517eae6f2bbc099ba4e24cfdd48e6baf092baaef4921e9665521eec54c741a7cae9bb4d03cadedb845f5d5cd631c46544709c3efc4d4103408a57f35c26 SHA512 c2bf2f0aa44c39d4c9b2865c7f0a8abea0956bbcaed38485de60b7baedcda0df2f71d34e4a6bb5355eccbaa8dcc21e8c1b47d948d968668e3e55c3e8d7f3efa4
diff --git a/dev-python/termcolor/termcolor-2.3.0.ebuild b/dev-python/termcolor/termcolor-2.3.0.ebuild
new file mode 100644
index 000000000000..9cbfe7932985
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="$(pypi_sdist_url) -> ${P}.py.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest