summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-06 23:35:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-06 23:35:15 +0100
commite863cb8850b3734386669ced72ba782bf20bde7a (patch)
tree30ab0c010e90446db06e608c1b8fe9616d58f546 /dev-python/tempest
parentfb6a7e84128cd7df87023d4e7d224de83057f748 (diff)
gentoo auto-resync : 06:05:2023 - 23:35:15
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest2
-rw-r--r--dev-python/tempest/tempest-34.2.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 967d46345f9f..b636603aa3e4 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
DIST tempest-34.1.0.tar.gz 1139228 BLAKE2B 32fefb49ad5a341d297cf660387e66f69e0f3f81cba5f0530190bf5562c7a391359667390045fd746977020376e426aea351a2f50652d67693946bdb8dcfba18 SHA512 89cb682edb3d99c22e9c654a9e546e649837abf7e0b798d84c16d70bef4527d094dd6bbe1d11b8996412cd7e6f073fd1a3f80e5214d7d3a44965f3b542fa13e5
+DIST tempest-34.2.0.tar.gz 1141098 BLAKE2B 60d09fc0de49e63213bf23cc223cec92b53f887ff5677fd80cefac441166ef777bc8b96682847697702af26d8481192a2fe19ddbe42cd3b991cc0f16ed09176d SHA512 22cf6e5b6d60398a7a1698ad0bad02d8d16ffd815f573fb526becb9d1be64151bc6b33fb6b8b03f9c52f18565ca06cad1bf9725f2cff2c6116c88f85439b5d7e
EBUILD tempest-34.1.0.ebuild 2196 BLAKE2B 3cecc6aa4d890879813eb5d205c32a157ce4419fba6a136b141b7479ba5589d7b2b3ea45112b462754a79dc27665e21be32c82cbd940026b127881d5bdc5723a SHA512 dafd6586cec20fdf6c91011b1cfcff774bbbb85c221529c82dda8341b637ec81ba63f79fcc1e053148502d003caf09b99a33dde861c6b717056c44b1c7967c73
+EBUILD tempest-34.2.0.ebuild 2199 BLAKE2B 807c0e451c8c8b24dc94429e5451dec69642328e3751d97dc62f572f6fe474f76042c332212cfbb4b1243b0729d8ff21eb1fbd8795f00a4058835b58f44c3858 SHA512 0f45ab8a3b36314818963e09372288de07325a79d28c4cfae116250d1ae962bf37938deac4c280ad61100470c39f1886a10fc7ea8d72de8e5521a5fd0924c7c2
MISC metadata.xml 442 BLAKE2B 30b474d10a59f53672390e029ffaf894cfe52862af42814ca09500372d4c94afc596177100b9ba69cfd12965e98809de363527d9db345c3b4cf499eaab0375f9 SHA512 d84466ecac31486c92a6c5f87089616b65a1f3cbe9447c3382021af57bec3964a80d4d4421783560528e80e70afb4f4ba604bf2a4e23ac7fcbd873ef3d789859
diff --git a/dev-python/tempest/tempest-34.2.0.ebuild b/dev-python/tempest/tempest-34.2.0.ebuild
new file mode 100644
index 000000000000..9143d3959fb9
--- /dev/null
+++ b/dev-python/tempest/tempest-34.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
+ local -x OS_TEST_TIMEOUT=300
+ eunittest -b -s tempest/tests -t .
+}