summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
commit750f865355947c40a4b93cd7a5db23eebc4e5080 (patch)
treed09084ef3a0baa1b4e6adbdbb4e85abc21f6650f /dev-python/tempest
parentc51985271f4c8e0bc79728c6cecf15d6b6515914 (diff)
gentoo auto-resync : 08:12:2022 - 21:16:36
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest2
-rw-r--r--dev-python/tempest/tempest-33.0.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index d61720552890..322990b8e839 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
DIST tempest-32.0.0.tar.gz 1121245 BLAKE2B 00cd2bf7f0869f9040134076e93ebb9d7aa56504788484ed0597d024afb74726df64aa2899dc021ba977cc01814e5e2213b46428d969a73d561e0056b5777d84 SHA512 8770a7067439977720916a8221554836c29afcb18f29716dc513c2eb9f5e09d9b7e123bf98dcb70dafb889594c431efb0367187622e5f0561b24e296a3613734
+DIST tempest-33.0.0.tar.gz 1126464 BLAKE2B 14bce9e0baf1878fc30cc5026c7849cda5abc0291706c7cd051827ffb1e15670e653a20ba6c0c898e86a7e1bee498d14139f82887606f5587b7775d18f96595f SHA512 1a34bc81a18121e3be05ab1a2b637aa8bfc41a0a8e11824294c78468762fb5f303ebf9607f5e72aed1cc5b130b26e22bf72c0574472a0de4eca083e899ff6eb0
EBUILD tempest-32.0.0.ebuild 2135 BLAKE2B aed4a3c33e8c909f1b40b8d9bb5b13cd38b038b340f0d156ceb6692238f6dfa04d7f2cb69d01728e590c9a16b9312f521ae1be418a9a9d4c846d7216ac77ae17 SHA512 62d4381d73e3d8bffa6e89cf8459553424e4059a09f897f34584d9c517a950531a2869aa1af0a3029fd4f5e17bcd4f01014f259d000397ecaba57de018064070
+EBUILD tempest-33.0.0.ebuild 2197 BLAKE2B 338dc75691cb3d1c91a70b7567734824cb49f3b1aaabdae3724ec98b79e1b3ab386c429b94916707283e37f39c9e97bbe8684ec1884c746767485dc7773e64ae SHA512 a9de8e89a97c067c07bfa590f81cca6248e59faecff9b22c6638f8d662396b8c23c191448f768a8eacce7ac31b81dfb79e015bc2df917f143948eaf65da00546
MISC metadata.xml 392 BLAKE2B cf7565379c5e1bed34940d0771212eea2a7ff81949678e0a645ce4d7d1c3da88febc0bb5a2ca968de8962d63610e37b0f3adc6e0661ae9de8c656d5ce0ae9c0a SHA512 41d760432a3c46d0fce432e6d431cac110e2c271796d0d04ee026347f01ff3add7db90edfdd83397190e5a563f04c835b250052763ea9daae788ac43519a769f
diff --git a/dev-python/tempest/tempest-33.0.0.ebuild b/dev-python/tempest/tempest-33.0.0.ebuild
new file mode 100644
index 000000000000..9a81d194616a
--- /dev/null
+++ b/dev-python/tempest/tempest-33.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
+ local -x OS_TEST_TIMEOUT=300
+ eunittest -b -s tempest/tests -t .
+}