summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/tempest
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest3
-rw-r--r--dev-python/tempest/tempest-29.2.0-r1.ebuild69
-rw-r--r--dev-python/tempest/tempest-30.0.0.ebuild69
3 files changed, 141 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 3013796ddc3d..f1320c78fb0c 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,6 @@
DIST tempest-29.2.0.tar.gz 1092824 BLAKE2B cad7284ab5a5a39a1a5bdf9f2365a85d337e4ebe17243bc3692a98402ef7f11b27b94e0252d9d427f358c343b736b500db5386098950c88b09f23d87de9ad856 SHA512 4042bce9c5d7cd26d652189d82ee91ac43d73a515b690820dfe05b70c2e792ec6f3bb0be5566bb37e81965015f62773414c8a16cc77512b1e52f141eafbd542d
+DIST tempest-30.0.0.tar.gz 1110715 BLAKE2B b697ecbced21124719e6b1d7ebd2c4f8ba83528a84da0b8f8109c155b61124581b97c180bbdc6885ae53850fb28daed25772d12be5026c44ecc3fe4f0dad98a3 SHA512 fa9be713ccb130ad065628592f59bebda3dc1fa8222ab3c382ec5b299504dc0a730f2110ef80f98bbdd1288b5785ab745fe39b721b77f7343983c1bc0a036f19
+EBUILD tempest-29.2.0-r1.ebuild 2083 BLAKE2B b7dfd73418ce1b7421e9603f345970011ad0e418f8f40140b6587803e1f89275b8e5be2867c527a8c3a1ac0c467710e8fa61eb25bdcaf21d4b3d3441e3b44848 SHA512 9bae7147ffa34b9126d8e2c2fb4acd1b2ad38abbf249537dd255f45232cc27eb97f65be3f0e7a6eccee4ab9add9802e99fd0a5e1e514dcadcc9f930f1193f8fb
EBUILD tempest-29.2.0.ebuild 2072 BLAKE2B a49c534b16aa4c138274636e0768bde40baa83e18adf7ab2c4dcadb3ac6fbae72dc9731e1f7232db167be6dd22809885be6fc32e572ec1167594135c769dfa6b SHA512 b4263e8b54261bcb63397995c7afd21cca4027c6a6d9d43d08cf99b7092284a69f18c8b0e96931d9e3347ce69bbdd0eb75d8f5691b646a56a2d991cab0fb2a36
+EBUILD tempest-30.0.0.ebuild 2083 BLAKE2B b7dfd73418ce1b7421e9603f345970011ad0e418f8f40140b6587803e1f89275b8e5be2867c527a8c3a1ac0c467710e8fa61eb25bdcaf21d4b3d3441e3b44848 SHA512 9bae7147ffa34b9126d8e2c2fb4acd1b2ad38abbf249537dd255f45232cc27eb97f65be3f0e7a6eccee4ab9add9802e99fd0a5e1e514dcadcc9f930f1193f8fb
MISC metadata.xml 402 BLAKE2B 9a28d185d29e8844299c1f6276b80759cb0ba7d0b9de14f70cb92f4bd69a4604aaffb7ed0cd0e65764099007a87de3e15c519dbdbc8a247d8ffe884613c7af5e SHA512 e9ef089f055cb4d6bb527f58d2e386d7796b2df34a8bb850c90f86cb98d08259b5ecd5e785389cfa6351f1319502c6822e3cf6a6250ac7dcd1838923b3deac87
diff --git a/dev-python/tempest/tempest-29.2.0-r1.ebuild b/dev-python/tempest/tempest-29.2.0-r1.ebuild
new file mode 100644
index 000000000000..e9f0d2aad3d1
--- /dev/null
+++ b/dev-python/tempest/tempest-29.2.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/tempest/tempest-30.0.0.ebuild b/dev-python/tempest/tempest-30.0.0.ebuild
new file mode 100644
index 000000000000..e9f0d2aad3d1
--- /dev/null
+++ b/dev-python/tempest/tempest-30.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}