summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/tempest
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest3
-rw-r--r--dev-python/tempest/metadata.xml13
-rw-r--r--dev-python/tempest/tempest-29.0.0-r1.ebuild60
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
new file mode 100644
index 000000000000..543fc5de2983
--- /dev/null
+++ b/dev-python/tempest/Manifest
@@ -0,0 +1,3 @@
+DIST tempest-29.0.0.tar.gz 1090497 BLAKE2B 520e9de1fc326d9a64d7ab5e93887f3bd455d9c47d29e0774bfb362b1baff6c1dd13fc6df2c756f0e73dd2b33ecb02ea61abdca9ea1ae68474ba53271c6c9e93 SHA512 03049d6cf0e77bac1afafad88b5b0fd22abaa40ed24ffd2c0c989dbadf277c09d703f0d9f7b34f4f68a4b5858b061ea9586ef66e26749b0822af0e426d1b81a7
+EBUILD tempest-29.0.0-r1.ebuild 1818 BLAKE2B 1d62c5f400c9266589719b13a7c325f13089e002b77e229393e6fb84b0ead1ebd73ee75dfd6a02d4210594cd94bea87ea15e12b90e17f3a6ad4fd1290a8e8872 SHA512 2c7f8beaf6de7d9f9ed278f38fe63b4eee4cdbae0b3ccfa6e45f396fc668a78ee0c7515835a019a311dbea5f6ae7f1172b359155341c42f55c2ce1939d3cae5c
+MISC metadata.xml 401 BLAKE2B 9a92d6bb9b20f86c1288c52b2a656367779e67602bf3bf1be4a21601f3141e4864916250418ca7bf1f13767f528cd4679fb6e1a18dca1143c3edde50b508cc0c SHA512 ba3015a097340042ba4580d59da46e12f6b34e2ee174c6ae775a5d7b71b4bcfbf04b52fcb871af76e0ec3bf592ec1485f1acdb4944a0a48ae77b6e8b958ac198
diff --git a/dev-python/tempest/metadata.xml b/dev-python/tempest/metadata.xml
new file mode 100644
index 000000000000..bbcebc294603
--- /dev/null
+++ b/dev-python/tempest/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">tempest</remote-id>
+ <remote-id type="github">openstack/tempest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tempest/tempest-29.0.0-r1.ebuild b/dev-python/tempest/tempest-29.0.0-r1.ebuild
new file mode 100644
index 000000000000..c8e27963678a
--- /dev/null
+++ b/dev-python/tempest/tempest-29.0.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+# A lot of fails and error of InvalidCredentials
+# The test suite expects full venv based on tox
+# Please test the package using manual tox run
+RESTRICT="test"
+
+distutils_enable_tests unittest
+
+python_test() {
+ distutils_install_for_testing --via-venv
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=160
+ eunittest -b
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}