summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
commit0a65aa74175d9ac6570321fe11725dc30c574e08 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /dev-python/tempest
parent4b4d352fc9761396c68812d8eccc63b7b14d6558 (diff)
gentoo auto-resync : 03:08:2022 - 13:55:12
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest4
-rw-r--r--dev-python/tempest/tempest-31.0.0.ebuild73
-rw-r--r--dev-python/tempest/tempest-31.1.0.ebuild2
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 6805d5e6731c..d7bae544ce29 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
+DIST tempest-31.0.0.tar.gz 1110051 BLAKE2B 9c3c87db902220e3e8de6e88e0d282eae07cb3b155eaa415156e83aff9d52523416fbfcae5b49a335eb81ae3488e4e2aa4cf86d10a35820aa3e24184466576d8 SHA512 9f8cfae192a5fe0fd5d6c1659ae42b5f2042392945e2c91b3bb96cecc412a1e6e582bc46ab481452012dc2440d13bc8298ca875587d5b1592dc95971d9adf4f0
DIST tempest-31.1.0.tar.gz 1114805 BLAKE2B 29c0f55db6812a4da6bdbce1159a7e5b87ef0caf4b21e0810b6c941633182da12b72675d86ec0f9f2b844d91258439305c059f6f03ed09d45f7758426c6c096f SHA512 56726d5c0aa8d576e3dc200d30a370be08fec178f357381f00ca08883ab1ccf56fbfaa53ec9322a5f4eb5383e0572f25d8cd277848bc0c3a3d12e57722860a2b
-EBUILD tempest-31.1.0.ebuild 2135 BLAKE2B aed4a3c33e8c909f1b40b8d9bb5b13cd38b038b340f0d156ceb6692238f6dfa04d7f2cb69d01728e590c9a16b9312f521ae1be418a9a9d4c846d7216ac77ae17 SHA512 62d4381d73e3d8bffa6e89cf8459553424e4059a09f897f34584d9c517a950531a2869aa1af0a3029fd4f5e17bcd4f01014f259d000397ecaba57de018064070
+EBUILD tempest-31.0.0.ebuild 2135 BLAKE2B d0c801530e7f5c9e19e607bcb7c2ac31ed6f5a322b8b294b641eb8494445fba7a3bf02632c2ea52ae521022a5e87108854eaf5af3fe3c4513a3f7f12aba56330 SHA512 8b02dcbf09d3e7025c50672a25f708fce68056a130262dfc363c1de74262d8fe064b5516a461a617b86e43f12c3d50527aa8de91f8bf5944bdd111a8db75f443
+EBUILD tempest-31.1.0.ebuild 2138 BLAKE2B c1c17ef2a0cce940b9befaafe8815d4707788a309b6aae90092adb35b7a0421d0b6a9aa886f217f64b097e617411901b49be719d81eaacd8a798dcf60072532f SHA512 9c321710e01ad2ab2181d023820838bc7ecceba6f9e4478d1d582a17e8f830069fb25a560884b52484886a1ae157089f56afe974a09a14514453d81e75d146ad
MISC metadata.xml 503 BLAKE2B c048e018345a8d306f22fb944e8f04db6fa8ab0e9e7099b19e0fd24ad69632d9dd1dfed9620c092f2f740e80e06556617b59cfdd0121101fa030dd6415aafa34 SHA512 39986e26bad2304333d43fd0ed1b12db5d9c56059d30ceb3868b6967f6655f50edaa232a86059da3434a4e219847c8f74e98972cecfa074a8bd28b76b3e3ccbb
diff --git a/dev-python/tempest/tempest-31.0.0.ebuild b/dev-python/tempest/tempest-31.0.0.ebuild
new file mode 100644
index 000000000000..bb9f3e885feb
--- /dev/null
+++ b/dev-python/tempest/tempest-31.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
+ eunittest -b -s tempest/tests -t .
+}
diff --git a/dev-python/tempest/tempest-31.1.0.ebuild b/dev-python/tempest/tempest-31.1.0.ebuild
index 003830d1993e..e5d757d4c5b8 100644
--- a/dev-python/tempest/tempest-31.1.0.ebuild
+++ b/dev-python/tempest/tempest-31.1.0.ebuild
@@ -18,7 +18,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
RDEPEND="
>dev-python/pbr-2.1.0[${PYTHON_USEDEP}]