summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
commit90cc39f2232ae2db1954af4df82965ad2960c174 (patch)
tree40a69f630c68a907a2114e099b74df3d4024bb8c /dev-python/tekore
parent2f3183511d8fcc1dd014e08f7c2535790512213d (diff)
gentoo auto-resync : 15:10:2023 - 05:27:58
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-5.1.1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 3ddd38322f6c..6dc80d5fb3ff 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-5.1.0.gh.tar.gz 261207 BLAKE2B 7c52fe1bd0a29da10d846d04543ccca5770e2e5682e5f816fd6ac56c0f351ba2374662187ab71350cf2e8c298175c045c1d35b4512f529b67aef11a4a80a8f15 SHA512 13c8853c707ee2234632e8f051b22df67935afa26c5f4c684728031a78ded88b9d71fff44093d9765a2287ecb5613b8b6b792727d632bce234d89a8668d86ca4
+DIST tekore-5.1.1.gh.tar.gz 261257 BLAKE2B d0ba6a3564f0be269ea3dab8ec2860cc17cff52949f0781fb368a82611b2b9bfd37a018ef9446e078003def5e89de8e5c4219a4c0154baf37cb6e453b7369d0e SHA512 0eb53cf242619a4646407c375a752877e82b231d187ffb3095eff33bdb3869a75c1194833487b7d377fbe9af6d9cb975714ea293a015743b7377a6eb0fd68424
EBUILD tekore-5.1.0.ebuild 1307 BLAKE2B f1f211f0e9abd189666ae74bbd8b917f4242d4b0a760fcb96eb9f2177f69f5672d14b5cf5b463c8c0989f3a806084072910a4cc56076817cbf6397cc47090547 SHA512 f3a9b6c913075912e43ac7c1d79f574ad47240c511fd96adc5c41e7d18efffc81e14abbdbbb7e1b6372ec3d863be48efc3b25b302c883766f44e1a37d6a140aa
+EBUILD tekore-5.1.1.ebuild 1307 BLAKE2B f1f211f0e9abd189666ae74bbd8b917f4242d4b0a760fcb96eb9f2177f69f5672d14b5cf5b463c8c0989f3a806084072910a4cc56076817cbf6397cc47090547 SHA512 f3a9b6c913075912e43ac7c1d79f574ad47240c511fd96adc5c41e7d18efffc81e14abbdbbb7e1b6372ec3d863be48efc3b25b302c883766f44e1a37d6a140aa
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.1.1.ebuild b/dev-python/tekore/tekore-5.1.1.ebuild
new file mode 100644
index 000000000000..98ce61f606a8
--- /dev/null
+++ b/dev-python/tekore/tekore-5.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.26[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+ # these tests use calls specific to pydantic-2
+ # TODO: reselect when we can depend on >=pydantic-2
+ tests/model.py::TestModel::test_enum_in_model
+ tests/model.py::TestModel::test_unknown_attribute_ignored
+)