summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 19:30:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 19:30:29 +0100
commit541eca7cf7b9950f0adaaf9158f94c76ba0aedc9 (patch)
treeb80d0f20ca0dc04843c819a54cc618cc8baf0479 /dev-python/tekore
parent4df758340c38fb7f188a6356561aeb4ed2c3f38c (diff)
gentoo auto-resync : 08:10:2022 - 19:30:29
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-4.4.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 976281342f1b..e8b28018cf19 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-4.4.0.gh.tar.gz 261768 BLAKE2B b0da919bd0feb32fa5770eb02cd817142d80f63e29602695b7cc6e9099203e502e61aab816ec3586595ab06f7f493243b13dd98cdb9e89913854e7cfcefcfd61 SHA512 86ef782971f1ea9d9f49e9683b27a8d9f70511e89a7fa7c8cffd01ba716782b1d91adcde2e24a52e42ec5b5b936005545ea1e15b067d1f109d2ecd2cebbd930d
+DIST tekore-4.4.1.gh.tar.gz 261791 BLAKE2B 380685868923bed258739bae67e1d1d57c5cdb23cfb43651c1400a38d40176ba9ad55780e1906b72afc97701918817341e7a2c501c0e7bfb2c57711920877f2e SHA512 f2eb0ee9852d2ef971974871890e5150eecdb30f5894301b22ec728852d680af0d476311b83f3ea4528d4d60cedf5379645aa7ea35015dd8beb1a9a9aeab4671
EBUILD tekore-4.4.0.ebuild 966 BLAKE2B 7ef834293663507e03df1e0d169d6d38877f9b0440844a8ae376e6314b9ccf69c3c7647a7a779c0975434e1f5fc9516b897299e9064752eca44eb7cbd0e65446 SHA512 4545bfdbedeb1c8cae1739a0ea21f6f0d37ed25797267cf0f8f4521a3d4dcc0e09eba6b463d4371cff9fa31456ef49171296d227b97c1b161b58add4964718a2
+EBUILD tekore-4.4.1.ebuild 966 BLAKE2B 7ef834293663507e03df1e0d169d6d38877f9b0440844a8ae376e6314b9ccf69c3c7647a7a779c0975434e1f5fc9516b897299e9064752eca44eb7cbd0e65446 SHA512 4545bfdbedeb1c8cae1739a0ea21f6f0d37ed25797267cf0f8f4521a3d4dcc0e09eba6b463d4371cff9fa31456ef49171296d227b97c1b161b58add4964718a2
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-4.4.1.ebuild b/dev-python/tekore/tekore-4.4.1.ebuild
new file mode 100644
index 000000000000..cd7308b5ca24
--- /dev/null
+++ b/dev-python/tekore/tekore-4.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.24[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx_rtd_theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)