summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 07:41:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 07:41:16 +0000
commit3e3aa158fd100df495010eed7915f012d5c9bcaa (patch)
treeeec12007aef38a8d8dbffd66d0e186f005fdc65c /dev-python/tekore
parent4560e1a95e1072b051371c59aec78b15e4787ded (diff)
gentoo auto-resync : 24:12:2023 - 07:41:16
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-5.3.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index c3732fb2fd75..93b14ec308ba 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-5.2.1.gh.tar.gz 262294 BLAKE2B 9572f4e45d4e90421b49697e816e4c83220af55360276f77ad86fd4469afdb214ec5dceab6e65170e9050d0e728f0f4998c99c30e6379c25c405f922b61ad853 SHA512 f91d9b166acf2a9906dff4aec00328221f4d54e6f833b982cc782168552284c29ddd03f8da052ccabd93dc2e7bbe72c95019599d6b57fcccd1561f36d7136e63
+DIST tekore-5.3.0.gh.tar.gz 262670 BLAKE2B 7d97a94ddb516e4c1fdfd391377d08b5df444fd4e753be6d7f8a41cd21ed118e27ee29a8364e69e564d94f31916f10511c1472aad2586c4ba016aa97ae8248f5 SHA512 5ff2520af36236a61be4681ebe5df011a67f0db9c2b88e58958368435f8c3a4c183f94657f9a84c16156cff54b856a8f93867ce2d475075ccffaf2230428c219
EBUILD tekore-5.2.1-r1.ebuild 1218 BLAKE2B 83a2b2a904b360c7177b4706191a69bf0bfcd81c3b6d6cb012fd630293a2158673122a775f69f44380227b1a3c6e8fc142475dd9a22ba31c0e0af443a2ea84f6 SHA512 421b43dafc59bb8a4d96c1a8d54257e0bb457fa3deeb4ac07f02ce897538a7f73004cb999bc200f2431bf02dc8755639dc8309dee5538300a46ef73cdcce0c59
+EBUILD tekore-5.3.0.ebuild 1218 BLAKE2B 83a2b2a904b360c7177b4706191a69bf0bfcd81c3b6d6cb012fd630293a2158673122a775f69f44380227b1a3c6e8fc142475dd9a22ba31c0e0af443a2ea84f6 SHA512 421b43dafc59bb8a4d96c1a8d54257e0bb457fa3deeb4ac07f02ce897538a7f73004cb999bc200f2431bf02dc8755639dc8309dee5538300a46ef73cdcce0c59
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.3.0.ebuild b/dev-python/tekore/tekore-5.3.0.ebuild
new file mode 100644
index 000000000000..6e7f60d52dae
--- /dev/null
+++ b/dev-python/tekore/tekore-5.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+
+ distutils-r1_src_prepare
+}