summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
commit2c9fab2a3468abc6862cb3115c9ff63aa266bf57 (patch)
treeb9249df06dd8229d7f334cb2e536d5c56ac81d3c /dev-python/tekore
parent0735b7c70f35339a20b45aee2a0a0ad80d118550 (diff)
gentoo auto-resync : 07:07:2023 - 10:16:30
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-5.0.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 74f0c4f7b36e..bf73fe976d09 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,5 +1,7 @@
DIST tekore-4.6.1.gh.tar.gz 264775 BLAKE2B 38371bfd377c51d0dc790ad1571573709b6f233e1174addb1621ae7603a50a3dfd7274d74243f95c51b94ab22143e69417ad02110a71d5db4d98516f29b9a308 SHA512 0e76434da0a03e2e808009ca471bcf2dae25db0cc27769d5df9ec1075ca177d3d6faaa35fbf3532646b6bad27dc503c8262361dda23127ee3b8bc4e4e4abfe06
DIST tekore-5.0.0.gh.tar.gz 261056 BLAKE2B 3d3659d68329b0cd4de655cae018b89ad0bbe0173087f11b3ad9cf6af0be60a6c0202978316321c4962ff6259126159b84d48a8dafe916f687a8098240d218dd SHA512 60e269bac72b7717f7f81a2865b4e317c7d4f161457b8c12073150dbc3a1ea8307c3256e28381cc4c7b1f1daf698c9083890f498d0d96067d4bd1df5f15b10da
+DIST tekore-5.0.1.gh.tar.gz 261087 BLAKE2B a5355f6604dee84cbd169b7de2574f5a46b5651784f9aa8201b56127dbac239c58548c8a1ae9928ba3da19a6275cf7f3eb4139d5a0402bb99548bfae051d89a3 SHA512 6c49f6434434d68845aa5e7de8cb2b2075921b9c27f36f2e5d8a8e0ea14996e7cf96e44bd2bc4081278c329e157c30c4aa95192b14d99df8bf607bce10cdd6a8
EBUILD tekore-4.6.1.ebuild 1011 BLAKE2B 2fa4bd9ffe99d16f09f3703d178321339b1c514c13a6f323e0f9e93fd04b5412af860998cf482421ef710137191f0f22041aed0c7613b7f2891c1a9175516b29 SHA512 23643578813361fdde6e78ac9b4f723c91ff608d1972b299271e2816261a27a3d02d2f20ff411f3809b6258755bb5fb498e60d5875f781092071eabedda43dc5
EBUILD tekore-5.0.0.ebuild 1192 BLAKE2B 923b64ba9bf0c603d4bb46c9e4921c593a9861e1fad2dd154b214e4d1995ac951205087eb22c8232a4d23efdf65767fe6074befac2fb2519f433c9e5ba626e04 SHA512 09114a1d55eec7b4cc3833c3410bd1eb93321d2d4874d96f89a73a68d07be32a3d264d970ca0f961f4dc199a792337f99e91a0000170fa1860124613164c9cd2
+EBUILD tekore-5.0.1.ebuild 1263 BLAKE2B 3265211cfc69c3bae92b3f47b8e21301d62c069bb7707b0449e516be62081b9a6ba6310b8205bcff9ee1b6b0c5cf3f3120b98d889dab570f79c0e29f983dd01c SHA512 2e89cc4e47c64d87f0a545dfdc5c70e53d4ffcc1e1a8144e0e3163cbf8c4e1d9c06ef4923f826622b2f8a863208ce9ffc9e27c852fcf25069724ca2050cc65ed
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.0.1.ebuild b/dev-python/tekore/tekore-5.0.1.ebuild
new file mode 100644
index 000000000000..e364947bea00
--- /dev/null
+++ b/dev-python/tekore/tekore-5.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.25[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+ # these tests use calls specific to pydantic-2
+ # TODO: reselect when we can depend on >=pydantic-2
+ tests/model.py::TestModel::test_enum_in_model
+ tests/model.py::TestModel::test_unknown_attribute_ignored
+)