summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
commit262a170a603cee433f640577f13472ab41a5d3aa (patch)
treec8cd6d9417b8a1f2275883279d2ceaedba7207f3 /dev-python/tekore
parent37cd441738bc6681ca075c01b6dd06056a27abbf (diff)
gentoo auto-resync : 19:06:2023 - 07:50:17
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-5.0.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index f35a77d9f969..b591a1739ba5 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-4.6.1.gh.tar.gz 264775 BLAKE2B 38371bfd377c51d0dc790ad1571573709b6f233e1174addb1621ae7603a50a3dfd7274d74243f95c51b94ab22143e69417ad02110a71d5db4d98516f29b9a308 SHA512 0e76434da0a03e2e808009ca471bcf2dae25db0cc27769d5df9ec1075ca177d3d6faaa35fbf3532646b6bad27dc503c8262361dda23127ee3b8bc4e4e4abfe06
+DIST tekore-5.0.0.gh.tar.gz 261056 BLAKE2B 3d3659d68329b0cd4de655cae018b89ad0bbe0173087f11b3ad9cf6af0be60a6c0202978316321c4962ff6259126159b84d48a8dafe916f687a8098240d218dd SHA512 60e269bac72b7717f7f81a2865b4e317c7d4f161457b8c12073150dbc3a1ea8307c3256e28381cc4c7b1f1daf698c9083890f498d0d96067d4bd1df5f15b10da
EBUILD tekore-4.6.1.ebuild 1011 BLAKE2B 2fa4bd9ffe99d16f09f3703d178321339b1c514c13a6f323e0f9e93fd04b5412af860998cf482421ef710137191f0f22041aed0c7613b7f2891c1a9175516b29 SHA512 23643578813361fdde6e78ac9b4f723c91ff608d1972b299271e2816261a27a3d02d2f20ff411f3809b6258755bb5fb498e60d5875f781092071eabedda43dc5
+EBUILD tekore-5.0.0.ebuild 1056 BLAKE2B 2fc6406bbc7893d7568d0ce576659d2c095eaa08ccc6cf5d4d8d6065ffa1ee676aa70b5a3133e0957417fa97755a5c7e0ab5128d44c0dfb5d5ff252b52bccf55 SHA512 123bfd3a80018217dfb39a510b6898894dd5faeff4256a51c0999211e74743fb92f8d20d90ab413d9db36dd932f3866d12a90850a7439742a9f1e761982f2739
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.0.0.ebuild b/dev-python/tekore/tekore-5.0.0.ebuild
new file mode 100644
index 000000000000..b3065a6e048c
--- /dev/null
+++ b/dev-python/tekore/tekore-5.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.25[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)