summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
commit1b2c0d19f75523db182b267901484f87abf732cf (patch)
tree3c4832e97c3846189d07c64c2eba333bf33b8ab2 /dev-python/tekore
parentdd851ab76c56a249df7a0ec052acd90940bc014f (diff)
gentoo auto-resync : 04:10:2023 - 23:52:39
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-5.1.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index b6f1c9ed1507..b25ffd2cc857 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-5.0.1.gh.tar.gz 261087 BLAKE2B a5355f6604dee84cbd169b7de2574f5a46b5651784f9aa8201b56127dbac239c58548c8a1ae9928ba3da19a6275cf7f3eb4139d5a0402bb99548bfae051d89a3 SHA512 6c49f6434434d68845aa5e7de8cb2b2075921b9c27f36f2e5d8a8e0ea14996e7cf96e44bd2bc4081278c329e157c30c4aa95192b14d99df8bf607bce10cdd6a8
+DIST tekore-5.1.0.gh.tar.gz 261207 BLAKE2B 7c52fe1bd0a29da10d846d04543ccca5770e2e5682e5f816fd6ac56c0f351ba2374662187ab71350cf2e8c298175c045c1d35b4512f529b67aef11a4a80a8f15 SHA512 13c8853c707ee2234632e8f051b22df67935afa26c5f4c684728031a78ded88b9d71fff44093d9765a2287ecb5613b8b6b792727d632bce234d89a8668d86ca4
EBUILD tekore-5.0.1.ebuild 1263 BLAKE2B 3265211cfc69c3bae92b3f47b8e21301d62c069bb7707b0449e516be62081b9a6ba6310b8205bcff9ee1b6b0c5cf3f3120b98d889dab570f79c0e29f983dd01c SHA512 2e89cc4e47c64d87f0a545dfdc5c70e53d4ffcc1e1a8144e0e3163cbf8c4e1d9c06ef4923f826622b2f8a863208ce9ffc9e27c852fcf25069724ca2050cc65ed
+EBUILD tekore-5.1.0.ebuild 1307 BLAKE2B f1f211f0e9abd189666ae74bbd8b917f4242d4b0a760fcb96eb9f2177f69f5672d14b5cf5b463c8c0989f3a806084072910a4cc56076817cbf6397cc47090547 SHA512 f3a9b6c913075912e43ac7c1d79f574ad47240c511fd96adc5c41e7d18efffc81e14abbdbbb7e1b6372ec3d863be48efc3b25b302c883766f44e1a37d6a140aa
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.1.0.ebuild b/dev-python/tekore/tekore-5.1.0.ebuild
new file mode 100644
index 000000000000..98ce61f606a8
--- /dev/null
+++ b/dev-python/tekore/tekore-5.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.26[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+ # these tests use calls specific to pydantic-2
+ # TODO: reselect when we can depend on >=pydantic-2
+ tests/model.py::TestModel::test_enum_in_model
+ tests/model.py::TestModel::test_unknown_attribute_ignored
+)