summaryrefslogtreecommitdiff
path: root/dev-python/tekore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-python/tekore
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest2
-rw-r--r--dev-python/tekore/tekore-4.6.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 7c343c910b08..2d088b9a4c66 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,3 +1,5 @@
DIST tekore-4.5.0.gh.tar.gz 265075 BLAKE2B 830a7c006ea13650ecc639bc8277d7022eed29fb92e13d4ff0bd98cb30f9bf2c53c9fb5dc88f3195938c22e12c8cc73a52517629c1db2d7bdc5e80360ea7b8bc SHA512 c69f47611447fec72fe2c4f09689dc93b8ff4dc94d430f213866b349c5867eeefd5351f3707b05648a74bd30576e4fd5d7e0c81203f5c7f90d54710433e25980
+DIST tekore-4.6.0.gh.tar.gz 264762 BLAKE2B 5cfff764fcf8f2072cb009a8c5471b4795846f6cee9757c9aea370191f3e3595a22190e939dc9b2bfebe18c07ce011a39c1ecce1abecf4f33a96560ea5071e9e SHA512 9013b5d02c15ad1e99861afe1b78b555f459940e4798738a8861f021659da0f333d71fa8322f056b40b405251af39bf3a820ac5507d735538a9913832c491eeb
EBUILD tekore-4.5.0.ebuild 1010 BLAKE2B 87739013bc5da9177c36c3ad1f71cf0954c352a2d413886f74133d4f216dc53eef77ad242532289bf094a1139fc61b9e43f95432a0014cbf6e0c88e64ebe71ed SHA512 46ba0eb1841dd6e618bf65c9174be282b1de652237f78a1c1774e7c46cfc0a2b5e46693540e6d164702915e5b48c53280665154878ffcdebb8d6a610652d17e1
+EBUILD tekore-4.6.0.ebuild 1010 BLAKE2B 16775b5e6bdf6caaf8b327a838e5125643a2a66f8e37b909a30d6dda4e8dfb5769e8fa225df3b58076da26c73def549b42ecb34c07f02f2fb2201134717cd4fc SHA512 e11a1121ef800c4a53833fa52ad0dd2d2c2464c40e3b6a1427bf0ec0dfec2547c1490fa4dc2438b52ce4555363a49b02a978a23d760d8ed3a7c2bc0957c3671b
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-4.6.0.ebuild b/dev-python/tekore/tekore-4.6.0.ebuild
new file mode 100644
index 000000000000..7ce5d6dcea4f
--- /dev/null
+++ b/dev-python/tekore/tekore-4.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.25[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)