summaryrefslogtreecommitdiff
path: root/dev-python/taskgroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
commit77922838ba6e7b5f546528626d41f2e7f3fc2c08 (patch)
tree1fd5f253063a75764253e522032b50626e1a508e /dev-python/taskgroup
parent691395139ec5ea80983f870451c53bb6fff8298a (diff)
gentoo auto-resync : 30:10:2023 - 21:45:44
Diffstat (limited to 'dev-python/taskgroup')
-rw-r--r--dev-python/taskgroup/Manifest3
-rw-r--r--dev-python/taskgroup/metadata.xml12
-rw-r--r--dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/taskgroup/Manifest b/dev-python/taskgroup/Manifest
new file mode 100644
index 000000000000..fafa4be9e96b
--- /dev/null
+++ b/dev-python/taskgroup/Manifest
@@ -0,0 +1,3 @@
+DIST taskgroup-0.0.0a4.tar.gz 8553 BLAKE2B b9fe9e2442ef8ea5972599a150ad8d2e41004a0aee2112e455d0b850c3833fb266fe2a6b730a4d8371eb3fff0d7101f2803d8708f3f9ea1159338495ca9255be SHA512 fc5a78de3d20fecd82a2c9a142ecf1df8f33f185a792f50b86558d7bb38d49307977a4db0709dbb806cca2a1d3aba46c86833c24973e155c3295437038581ab7
+EBUILD taskgroup-0.0.0_alpha4.ebuild 573 BLAKE2B fea588893a17ae639ba11d6118ea3a16c6da7c303bd264f582da46dbe58edb5335b288085c3fe23a94dadde49bf1d113b157ed7a1617e4d327d65294498977ad SHA512 6318eaa38cf14b94b5f3341f848f60cd93899f244ef5dac8db109f64517f7e676feeda0f5d5ecbb861df21e291df8ab05ec3b8329f699b1d67de8e52c4cd571d
+MISC metadata.xml 374 BLAKE2B 4425ffec98ce921bb6bd596ef700ef8ef48a4505f8e40479cf92c3875bbea8647fad6df630ec0565e6095b21b657aa75d9e300841377c0e6347b40733a5f02b6 SHA512 e42dafb7906bc1c6779329c65d0076f2974c29ee8dff808a225f1644790eda644ac6feb8fa85f4542b874c86428031965ab3622863673f28a0f95bde4716e34c
diff --git a/dev-python/taskgroup/metadata.xml b/dev-python/taskgroup/metadata.xml
new file mode 100644
index 000000000000..19dd71f0897d
--- /dev/null
+++ b/dev-python/taskgroup/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">graingert/taskgroup</remote-id>
+ <remote-id type="pypi">taskgroup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild b/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild
new file mode 100644
index 000000000000..67c4cb856cef
--- /dev/null
+++ b/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_10 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of asyncio.TaskGroup, asyncio.Runner and asyncio.timeout"
+HOMEPAGE="
+ https://github.com/graingert/taskgroup/
+ https://pypi.org/project/taskgroup/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.8[${PYTHON_USEDEP}]
+"