summaryrefslogtreecommitdiff
path: root/dev-python/tagpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/tagpy
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/Manifest2
-rw-r--r--dev-python/tagpy/tagpy-2018.1-r3.ebuild (renamed from dev-python/tagpy/tagpy-2018.1-r2.ebuild)19
2 files changed, 8 insertions, 13 deletions
diff --git a/dev-python/tagpy/Manifest b/dev-python/tagpy/Manifest
index a58180f3263d..2e08a6685370 100644
--- a/dev-python/tagpy/Manifest
+++ b/dev-python/tagpy/Manifest
@@ -1,5 +1,5 @@
AUX tagpy-2018.1-readme.rst 725 BLAKE2B f40dbe6ab4f03fe0a6141a03ae6f504d202a5c97d605cb22dfa0b9695374260658f8dde0d49e84de0e7d289bff705beed1244215e70cc7f9d8d587d505322a20 SHA512 0d9cd79986a16ad78e76911f9d3c1b36fb706c74c58e9d29dce817bcf4bbd8b29c9596f1228a0524fdf6538f2c685901a159fd9bd0b629d0dd1d60c75c2820b0
AUX tagpy-2018.1-taglib-1.8.patch 642 BLAKE2B 45c190b621dda7368583c1ab92a01f08fb84d83666953caa5f05c89803db16dc8cd1668e3b891c757c916d27439c4c3143a8a8a2115ad89a8b2f1806dc4a80c9 SHA512 6a3af752fdfd12f6c5f6e52019f3d4f322b9dc3595e810e93ed43e680c1a2f7728efeb8d1180473ca3dfaa7f548d437c32f0a306882ad7f7072388f57ea42caf
DIST tagpy-2018.1.tar.gz 145501 BLAKE2B acdda6789dae000ba2f664e4a5582f6218f312bed20ec81c4ea54f358bec70d41aceed6704f392a7a32c39d263da81f9c832922942fa179e1865e423dcf28bcf SHA512 2010baa919adadc9fc231deeb093953622ec54c8b6011e2d6a3489b086032de0a71cc26f42439435f26bd7a1ff069e3944dafc61217abe6ea5e81b01b9d18c50
-EBUILD tagpy-2018.1-r2.ebuild 1189 BLAKE2B fc61427e82816e54bf27e1514d5e5b2ce76ee19873a0f3d45a4ee3ae1973d0772682111b15049c7bff3c5fb8778535429de4dc4dca3e394b997a394077319dd8 SHA512 303087d49160c8c62e56d4a27d2f2c403977b28e02327d750294724753c2db5236be59bcafd3f86a222c991b7d54f861a85176dc190845b58fed063afdb59de0
+EBUILD tagpy-2018.1-r3.ebuild 1101 BLAKE2B abe29c73119ab171bdd96a4f4dad3fcffe1d7789cf40aa9e9f1bcb7aeb194d10b6fd8b4b51a541e5f97560e801dabd0d6456615bc90cb4c819182cdc2958227f SHA512 19ecd9817309c9c1b3b014eb42908cfebd2999e004627581c2bd6ddf57874c911b99da3b3aedc399ca2efea0c655b1ed86e922b2ef59dda545268bfe9101842f
MISC metadata.xml 548 BLAKE2B 09356a368b0d4c31f10b55afd41560e273fcf85559d7613581be149d41692c48a5441be38f783cacf241925314e4c808309cb68569d8d78d130e8fce7fe539c3 SHA512 39098fc39a9f32b45b95410cb406e0a755dc8d3906168e356253ac14d35fb06a7d68c5ca37f63516d7803442986e4c8e61831f3721e52dd094374dca12d331a0
diff --git a/dev-python/tagpy/tagpy-2018.1-r2.ebuild b/dev-python/tagpy/tagpy-2018.1-r3.ebuild
index 1d343447f936..92001e25ca96 100644
--- a/dev-python/tagpy/tagpy-2018.1-r2.ebuild
+++ b/dev-python/tagpy/tagpy-2018.1-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1
+inherit edo distutils-r1
DESCRIPTION="Python Bindings for TagLib"
HOMEPAGE="
@@ -23,10 +23,10 @@ RDEPEND="
>=media-libs/taglib-1.8"
DEPEND="${RDEPEND}"
-distutils_enable_tests pytest
-
PATCHES=( "${FILESDIR}"/${P}-taglib-1.8.patch )
+distutils_enable_tests pytest
+
python_prepare_all() {
cp "${FILESDIR}"/${P}-readme.rst README.rst || die
distutils-r1_python_prepare_all
@@ -35,16 +35,11 @@ python_prepare_all() {
python_configure() {
local boostpy_ver="${EPYTHON#python}"
- "${EPYTHON}" configure.py \
+ edo "${EPYTHON}" configure.py \
--taglib-inc-dir="${ESYSROOT}"/usr/include/taglib \
--boost-python-libname="boost_python${boostpy_ver/\.}"
}
-python_test() {
- cd test || die
- "${EPYTHON}" *.py || die "Testsuite failed under ${EPYTHON}"
-}
-
python_install_all() {
if use examples; then
docinto examples