summaryrefslogtreecommitdiff
path: root/dev-python/tabulate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
commitfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (patch)
treeef1849fa20636bdbda9fa704f3bfba6ee73bd418 /dev-python/tabulate
parent7db983f17e59dfa621d994bcbdbddc71a6e70a57 (diff)
gentoo auto-resync : 09:11:2022 - 09:25:48
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest2
-rw-r--r--dev-python/tabulate/tabulate-0.8.10.ebuild56
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index 28d5c13b4c79..3d0072d17a8a 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1,5 +1,3 @@
-DIST python-tabulate-0.8.10.gh.tar.gz 49453 BLAKE2B 9bf5c9e937f8ef051792fc57dcd56f1150636bf29493fabe56d4b706df04add41fdffbe1108cb93aa561edc96245ba85e621d4a8b402ace513b55710e6e5498c SHA512 d216076112c0d0f0879c1eeecf2d2c0c30edc84d7289396f1a8d24bca862ef90fcf221a09812b409547696c3b7d4472d431043e359c3a7f67bb8392ce1e95ddc
DIST python-tabulate-0.9.0.gh.tar.gz 59342 BLAKE2B dc101ab8d1411196619c3d77dd83c84e48f31e148ec3878c2b844a1e26ea1187cc948cfb1eb740d61a667d6b669806a5288c397ea7fcbd59685fedaa9bd0bd2e SHA512 26b0f079f1aca48578883147cb1a2e30e96e0bb85d5af3b72b26eba5f73cea41cf1a0686f666487c8374f95ca0412703168e480c947f1567e6408f941756498b
-EBUILD tabulate-0.8.10.ebuild 1287 BLAKE2B f05fe2089ed8092f04ca65d90e1e1fdbbb0870bed8cc56948f16e30a5200ccec8a6379734c68c07b9989a55185d1fad682cb7f17096948ad39abdc613697cc72 SHA512 00b891e8cb2a64e594555a94dfdddc604ba18c587f680664762d9279004d1f38d75525421e080d27e32de702b11265d7fea374c34ac15a1d6cac38a3c930b220
EBUILD tabulate-0.9.0.ebuild 1332 BLAKE2B 2d83659a91876ffecd8f8aed4bfd6ccac5e1eea61bf97c8f0372faeb8e2eb2819020112576a1cfb6b294457338efe4a74edc947d92e3f225876e42b5339e5a32 SHA512 f822cc919e9ad3c43e04122f1a7895d83f848f4f1ecfb28feb1af4ee31da0c4e060788b77620d8bc7be6357dc702a39f7e9593b8f6046adb41ec5370825ac9e7
MISC metadata.xml 399 BLAKE2B b92bc308afead78cb604ddc6bc288fb28ed5a2a523c890270ee87eb5bfee21133748c5861829bafcc8a7b3401b430dff84dd99264ebf3e7ea74342f99ee8cfc5 SHA512 2d8c4dca9558e5a5d6413a6bd5e2cd6e15d1d0d447e6c692af84c8575be899f3d78246782e6c908a626326662aaffde56b2c3f96f4e9cfa0473c976109e3dcac
diff --git a/dev-python/tabulate/tabulate-0.8.10.ebuild b/dev-python/tabulate/tabulate-0.8.10.ebuild
deleted file mode 100644
index 8c3e9b4a5657..000000000000
--- a/dev-python/tabulate/tabulate-0.8.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-MY_P=python-${P}
-DESCRIPTION="Pretty-print tabular data"
-HOMEPAGE="
- https://github.com/astanin/python-tabulate/
- https://pypi.org/project/tabulate/
-"
-SRC_URI="
- https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- $(python_gen_impl_dep 'sqlite')
- dev-python/colorclass[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ' 'python3*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- test/test_input.py::test_pandas
- test/test_input.py::test_pandas_firstrow
- test/test_input.py::test_pandas_keys
- test/test_output.py::test_pandas_with_index
- test/test_output.py::test_pandas_without_index
- test/test_output.py::test_pandas_rst_with_index
- test/test_output.py::test_pandas_rst_with_named_index
- )
- fi
- epytest
-}