summaryrefslogtreecommitdiff
path: root/dev-python/tabulate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/tabulate
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest3
-rw-r--r--dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch80
-rw-r--r--dev-python/tabulate/tabulate-0.8.9.ebuild22
3 files changed, 16 insertions, 89 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index 1a3af9482adf..c32546e555b7 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1,4 +1,3 @@
-AUX tabulate-0.8.6-avoid-pandas-dep.patch 2513 BLAKE2B afbaef53282fa6b775bd3a1a1edeca04cf11f37a86e51ac94641b9037384ca54d808adba9196d057a9007559cd6b7b9ad442e94a8ca1f7f54ac6ef609e72c47d SHA512 7fab4bd5a493c6f6831e88f8e26497b09614f6b04b651c96d5c44639ed03531c14dcee9412970cd2f24e056dc4046a3d3ea708083a14d14ab952921ae7fb7534
DIST tabulate-0.8.9.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
-EBUILD tabulate-0.8.9.ebuild 847 BLAKE2B 4455c2854730f5fb217f572fc4198cb6eec537d5111a6f9dfbaaf5a5c67c1abaf58ec65cab1c5e844f8afef625485616f1ed6b999744d0f8f28526c471201b9a SHA512 d5908ff07b31c8e0d427040c4bdef44a3583d5f6e019885cc8d3d52e82cb1e51883fbd5e6b54fcde9cfef2ddac17c5e6e0e74484e81184509a6e5a2ed3daf6e5
+EBUILD tabulate-0.8.9.ebuild 1171 BLAKE2B 7452d7fc3bf7715446a0d15eb94f7142a691f09acaab3ae1c74363f79e32af65c49ab74ecec8d0b908d2a12a3eb544fdd9dd9db4689615484c0dec4e1d3fb850 SHA512 c8e93d12c29881c39631b92fd428fae62d90d01a3fcaaad7324ee4646a5636a194fee3903f8492dcf18c5a50f1129916ec8e8af90ef5833b66f8817d7ec797bf
MISC metadata.xml 398 BLAKE2B 3d07c5c3361c606537260a267c25d62b8564c3491a65aa425b418a9a58eb137d23ae7a0902e61b4fda33a5d693e9e1ae7f45d6c1d3eee24b46ad88b817c93868 SHA512 4ddb470a137b30099d06b9577f4dc2d5188185b3ec74393e0b8d3e7a388a20134e91bcc0ff0ddb782c6fbc07b95d72ad43fa5ffabc4a0587d0b94b0faae1dfcf
diff --git a/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch b/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
deleted file mode 100644
index b75df197f80e..000000000000
--- a/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff --git a/test/test_input.py b/test/test_input.py
-index 5443ab9..8a1d2e5 100644
---- a/test/test_input.py
-+++ b/test/test_input.py
-@@ -4,6 +4,7 @@
-
- from __future__ import print_function
- from __future__ import unicode_literals
-+import unittest
- from tabulate import tabulate
- from common import assert_equal, assert_in, assert_raises, SkipTest
-
-@@ -246,6 +247,7 @@ def test_numpy_record_array_headers():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas():
- "Input: a Pandas DataFrame."
- try:
-@@ -267,6 +269,7 @@ def test_pandas():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_firstrow():
- "Input: a Pandas DataFrame with the first row as headers."
- try:
-@@ -285,6 +288,7 @@ def test_pandas_firstrow():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_keys():
- "Input: a Pandas DataFrame with keys as headers."
- try:
-diff --git a/test/test_output.py b/test/test_output.py
-index 1eb67c1..2106c88 100644
---- a/test/test_output.py
-+++ b/test/test_output.py
-@@ -4,6 +4,7 @@
-
- from __future__ import print_function
- from __future__ import unicode_literals
-+import unittest
- import tabulate as tabulate_module
- from tabulate import tabulate, simple_separated_format
- from common import assert_equal, assert_raises, SkipTest
-@@ -1176,6 +1177,7 @@ def test_unaligned_separated():
- assert_equal(expected, result)
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_with_index():
- "Output: a pandas Dataframe with an index"
- try:
-@@ -1199,6 +1201,7 @@ def test_pandas_with_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_without_index():
- "Output: a pandas Dataframe without an index"
- try:
-@@ -1222,6 +1225,7 @@ def test_pandas_without_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_rst_with_index():
- "Output: a pandas Dataframe with an index in ReStructuredText format"
- try:
-@@ -1247,6 +1251,7 @@ def test_pandas_rst_with_index():
- raise SkipTest() # this test is optional
-
-
-+@unittest.skip("avoid extra unnecessary deps")
- def test_pandas_rst_with_named_index():
- "Output: a pandas Dataframe with a named index in ReStructuredText format"
- try:
diff --git a/dev-python/tabulate/tabulate-0.8.9.ebuild b/dev-python/tabulate/tabulate-0.8.9.ebuild
index a8028f272d89..fd5ed0277274 100644
--- a/dev-python/tabulate/tabulate-0.8.9.ebuild
+++ b/dev-python/tabulate/tabulate-0.8.9.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Pretty-print tabular data"
@@ -27,8 +25,18 @@ BDEPEND="
)
"
-PATCHES=(
- "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
-)
-
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # avoid pandas dependency
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ epytest ${deselect[@]/#/--deselect }
+}