summaryrefslogtreecommitdiff
path: root/dev-python/tabulate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/tabulate
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest6
-rw-r--r--dev-python/tabulate/tabulate-0.8.10.ebuild56
-rw-r--r--dev-python/tabulate/tabulate-0.8.9-r1.ebuild56
-rw-r--r--dev-python/tabulate/tabulate-0.8.9.ebuild42
4 files changed, 116 insertions, 44 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index 0c8bf8119f1e..bd03041d48f4 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1,3 +1,5 @@
-DIST tabulate-0.8.9.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
-EBUILD tabulate-0.8.9.ebuild 1171 BLAKE2B 7452d7fc3bf7715446a0d15eb94f7142a691f09acaab3ae1c74363f79e32af65c49ab74ecec8d0b908d2a12a3eb544fdd9dd9db4689615484c0dec4e1d3fb850 SHA512 c8e93d12c29881c39631b92fd428fae62d90d01a3fcaaad7324ee4646a5636a194fee3903f8492dcf18c5a50f1129916ec8e8af90ef5833b66f8817d7ec797bf
+DIST python-tabulate-0.8.10.gh.tar.gz 49453 BLAKE2B 9bf5c9e937f8ef051792fc57dcd56f1150636bf29493fabe56d4b706df04add41fdffbe1108cb93aa561edc96245ba85e621d4a8b402ace513b55710e6e5498c SHA512 d216076112c0d0f0879c1eeecf2d2c0c30edc84d7289396f1a8d24bca862ef90fcf221a09812b409547696c3b7d4472d431043e359c3a7f67bb8392ce1e95ddc
+DIST python-tabulate-0.8.9.gh.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
+EBUILD tabulate-0.8.10.ebuild 1289 BLAKE2B 3f663b2d1094d20ca3b634cfe4439c8c2cfc4b9f5cb274b276f49210df63f01f5bd158397cfcdc1e10d0d89a7f1c8092eb70b6a762b02ab82e732bbe0fcb3638 SHA512 2ad30f43fc0e29c40093da2626b1adefe59c188a93db6e5c5253c29206f7a4c04bab07975693adff661b4c4d879368c5819df9d5fa3ef53d96a9dd9c6672f91f
+EBUILD tabulate-0.8.9-r1.ebuild 1287 BLAKE2B f05fe2089ed8092f04ca65d90e1e1fdbbb0870bed8cc56948f16e30a5200ccec8a6379734c68c07b9989a55185d1fad682cb7f17096948ad39abdc613697cc72 SHA512 00b891e8cb2a64e594555a94dfdddc604ba18c587f680664762d9279004d1f38d75525421e080d27e32de702b11265d7fea374c34ac15a1d6cac38a3c930b220
MISC metadata.xml 399 BLAKE2B b92bc308afead78cb604ddc6bc288fb28ed5a2a523c890270ee87eb5bfee21133748c5861829bafcc8a7b3401b430dff84dd99264ebf3e7ea74342f99ee8cfc5 SHA512 2d8c4dca9558e5a5d6413a6bd5e2cd6e15d1d0d447e6c692af84c8575be899f3d78246782e6c908a626326662aaffde56b2c3f96f4e9cfa0473c976109e3dcac
diff --git a/dev-python/tabulate/tabulate-0.8.10.ebuild b/dev-python/tabulate/tabulate-0.8.10.ebuild
new file mode 100644
index 000000000000..699b1e2f6b7c
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="
+ https://github.com/astanin/python-tabulate/
+ https://pypi.org/project/tabulate/
+"
+SRC_URI="
+ https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ fi
+ epytest
+}
diff --git a/dev-python/tabulate/tabulate-0.8.9-r1.ebuild b/dev-python/tabulate/tabulate-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..8c3e9b4a5657
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.9-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="
+ https://github.com/astanin/python-tabulate/
+ https://pypi.org/project/tabulate/
+"
+SRC_URI="
+ https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ fi
+ epytest
+}
diff --git a/dev-python/tabulate/tabulate-0.8.9.ebuild b/dev-python/tabulate/tabulate-0.8.9.ebuild
deleted file mode 100644
index fd5ed0277274..000000000000
--- a/dev-python/tabulate/tabulate-0.8.9.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Pretty-print tabular data"
-HOMEPAGE="https://pypi.org/project/tabulate/ https://github.com/astanin/python-tabulate"
-SRC_URI="https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/python-${P}"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/wcwidth[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_impl_dep 'sqlite')
- dev-python/colorclass[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # avoid pandas dependency
- test/test_input.py::test_pandas
- test/test_input.py::test_pandas_firstrow
- test/test_input.py::test_pandas_keys
- test/test_output.py::test_pandas_with_index
- test/test_output.py::test_pandas_without_index
- test/test_output.py::test_pandas_rst_with_index
- test/test_output.py::test_pandas_rst_with_named_index
- )
- epytest ${deselect[@]/#/--deselect }
-}