summaryrefslogtreecommitdiff
path: root/dev-python/tabulate/tabulate-0.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/tabulate/tabulate-0.8.6.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/tabulate/tabulate-0.8.6.ebuild')
-rw-r--r--dev-python/tabulate/tabulate-0.8.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/tabulate/tabulate-0.8.6.ebuild b/dev-python/tabulate/tabulate-0.8.6.ebuild
index d8c753700d32..845c0f609e16 100644
--- a/dev-python/tabulate/tabulate-0.8.6.ebuild
+++ b/dev-python/tabulate/tabulate-0.8.6.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -18,9 +19,9 @@ KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/wcwidth[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
${RDEPEND}
$(python_gen_impl_dep 'sqlite')