summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /dev-python/sympy
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.13.3.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 4735c8ff6803..50a8a8014cda 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
DIST sympy-1.13.2.gh.tar.gz 8141028 BLAKE2B 7a51fa75f1733364d467b79174b71ba866751399d311212144fdc3abdc8cea99618baf0b0fe3f2fe4cb9ab7153ecae4fe4bf00716e97ea4466637633f5618089 SHA512 87f7da425ed577e78392671cb635c99a11f3d6431b8c49a41611f4d2be5da1cadd8d07e0e684f2674792a2ee750b4031baec53156e7192d4c47714d4537c3222
+DIST sympy-1.13.3.gh.tar.gz 7919933 BLAKE2B 94c601e79caf87eb0f08e15ca4cb79e16bcd97d347e1fd948b6ea98b044133ea99f52032f09e290668e4485393425254ff4062ccfd3a3ac0b8afba080da6ba19 SHA512 2ae7a400d4a2d9c826cfaa165e3e1f5d9ba210c25647984d997775d4ec3d7c8f3ad3c5468d9adf141a1dceec864ca988b4f3a01fd934b923c4486ddd458670a3
EBUILD sympy-1.13.2.ebuild 3047 BLAKE2B 22529829e33b29fe99541f4e69d3376d308bf8f899bd87172c3b56fce3fa46bcb46797f9a4b7887ca3bf73ea971365d9b8e215ab1d87b585939fb7cc28f8e2c3 SHA512 9c35247bbae7f1a22116e66df20e51384b8dd24d413ae295647d96f92afbbdc39aabe71d2f6a56a74d7fa19bf34e5a4be7fbbf0bab1a060fc0626f80b96c8813
+EBUILD sympy-1.13.3.ebuild 2947 BLAKE2B 4c6a17444c54988d35e52fa26433ffd1bff105d7a41ca973c847ef43e7d4bf9898a06094ba33dfa769ba0e723d59efc4b848836183132f5f5c956f13e6737008 SHA512 8f4d05ae6689966215aff9caf97f550c5d1649892b39250b750cc78d1db403b16197379fd95d22c9c5c22f455c2132da2e486ef8263ca60c3fd637e6d297a5df
MISC metadata.xml 1639 BLAKE2B b539888e4658c640442db1cb6bd6561664ee6c50109926d69572f4e2cfcdbef230a56909e799b09b860a8688ce66455ae5c5ac86099893ba667feb0198f65abe SHA512 9ba4c310c759e9e7fa3a726850b342e79ed07e4ab369ad126a35b1741fd4d343ba75af457cfcd76c5539b3259e0eb198fb58ae965c231bb38a94c83c00f52e48
diff --git a/dev-python/sympy/sympy-1.13.3.ebuild b/dev-python/sympy/sympy-1.13.3.ebuild
new file mode 100644
index 000000000000..b86ea4f35e26
--- /dev/null
+++ b/dev-python/sympy/sympy-1.13.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="
+ https://www.sympy.org/
+ https://github.com/sympy/sympy/
+ https://pypi.org/project/sympy/
+"
+# pypi sdist misses some files, notably top-level conftest.py, as of 1.12.1_rc1
+SRC_URI="
+ https://github.com/sympy/sympy/archive/${PV/_/}.tar.gz
+ -> ${P/_/}.gh.tar.gz
+"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="imaging ipython latex mathml opengl pdf png pyglet symengine texmacs"
+
+RDEPEND="
+ >=dev-python/mpmath-1.1.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # TODO; virtx?
+ sympy/plotting/pygletplot
+ )
+ local EPYTEST_DESELECT=(
+ # require old version of antlr4
+ sympy/parsing/tests/test_autolev.py
+ sympy/parsing/tests/test_latex.py
+ # crash due to assertions in sys-devel/llvm[debug]
+ sympy/parsing/tests/test_c_parser.py
+
+ # TODO: pytest?
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_check
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_dsolve_dotprodsimp
+
+ # either very slow or hanging
+ sympy/solvers/ode/tests/test_systems.py::test_linear_new_order1_type2_de_lorentz_slow_check
+ sympy/integrals/tests/test_failing_integrals.py::test_issue_15227
+ sympy/matrices/tests/test_matrices.py::test_pinv_rank_deficient_when_diagonalization_fails
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type1
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
+
+ # known broken
+ # https://github.com/sympy/sympy/issues/26321
+ sympy/solvers/tests/test_simplex.py::test_lp
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --veryquickcheck ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}