summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/sympy
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.9.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 5a3fbc8b1b3c..13428481983c 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
DIST sympy-1.8.tar.gz 7167842 BLAKE2B 878c6daf0584c9da54f82b9c68c62715792db428ab4ebfb355f0368c52edb254947d1ce1919e651279b767295ecb00a76b8cbbaa1fbe9c97915221c7403c3ded SHA512 61141e1d0a6105e725fb415edbdf981b3aa95debcfe73f9da5ca36afc7a70e91b5c28ed45454054c1b9a8d45e42bfe724e5b20da717746c301fd095da17f4db7
+DIST sympy-1.9.tar.gz 7476018 BLAKE2B 5ab9920bf6d16eaed3af30100e7593551a4dce29dc76605ccf87d55e8a7c14514b5733c9456353403cfc96008fd5d046ce04f44bb7e69f844d545bdd3e55e7e0 SHA512 139712219ba6bf420ba89b3f8d086ab8883c5ab965e9308ba9ee665ac3ac69a9b16fa30c6f5dfbc77dd34873ff3ff95c0d058954d7f9d853f5e9537efc24dd3c
EBUILD sympy-1.8.ebuild 1629 BLAKE2B 98bc6eb8534cb5c756c66218dbe6735c03b6439846aae74c40546e4f65250e6b3fafe10521cdc949dfb8a431b3ba3669a82fabb1495308306f238ed84b94785c SHA512 6665e0cfceb59ca8ea6ea175688a6b08e442dabc42f9d940252ed1659b2b85d600bf647ce680efa96ac61f8c14bdc2a6bfc82a17b764b63ab94562b4f121d8f1
+EBUILD sympy-1.9.ebuild 1599 BLAKE2B 1ef83c68c19b94579c76b82201462ef87b3138f5d1c067985b956036c288a561b9ddc753b00e2edb06ce9b696ae2a0b30b8fdc7c3fbefc486200c1dda299ace7 SHA512 6329c9eaed38fbe5bdfb3370b6a995b05408ce7ea74843ba0bb9f6fc78cb43594a8a95d852d57fe95ad7b57abcc48afa2a6a23907415ddf5789d3b398186dfd3
MISC metadata.xml 1715 BLAKE2B 8e7464f09c9d4b88e448c70a041ee1c3693587dffacf697ec6c13c069b90973f6be1e0f50fa40ebe9b12e7a33f1bf21e175e445563ea639bfb2a96dcae5ab96a SHA512 f5baf2997f559dee17355a7612b479dbd13048376f2bb2b26401150502d59eaf500066880379d9bbbe4ee7ba29e99821a27067d2e2df284bbfda9fb99058b23c
diff --git a/dev-python/sympy/sympy-1.9.ebuild b/dev-python/sympy/sympy-1.9.ebuild
new file mode 100644
index 000000000000..4524a6f67278
--- /dev/null
+++ b/dev-python/sympy/sympy-1.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://www.sympy.org/"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
+
+RDEPEND="
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ aesara? ( dev-python/aesara[${PYTHON_USEDEP}] )
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}