summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-16 08:45:29 +0100
commit79851ef7da5ffce7aed667c8c49a1ce04333619e (patch)
treed02a27f205d4bf84ecc872e84d0580f49708a86c /dev-python/sympy
parentdfd0139069bb79941b882fe714d38b7fc8dcdb16 (diff)
gentoo auto-resync : 16:04:2025 - 08:45:29
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.14.0_rc1.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 448304ea9cdf..71b2293bf3d0 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
DIST sympy-1.13.3.gh.tar.gz 7919933 BLAKE2B 94c601e79caf87eb0f08e15ca4cb79e16bcd97d347e1fd948b6ea98b044133ea99f52032f09e290668e4485393425254ff4062ccfd3a3ac0b8afba080da6ba19 SHA512 2ae7a400d4a2d9c826cfaa165e3e1f5d9ba210c25647984d997775d4ec3d7c8f3ad3c5468d9adf141a1dceec864ca988b4f3a01fd934b923c4486ddd458670a3
+DIST sympy-1.14.0rc1.gh.tar.gz 7910059 BLAKE2B aee2c8c737497204be6ebceacfb516c49a027bb715975c636b76b959e4fab13a5bd2d59e516c56f9722633e3234af573a988f17bfab484bbd26f0d30ee5a8c69 SHA512 567c713eeb8cddbf8238afd46a5aba1931427e7a9834a779007c91018ae2d108ebc3f8cfba185a757109c46c2817a29d0dc04d7d419b1b619bcba52b899e3e3e
EBUILD sympy-1.13.3.ebuild 2857 BLAKE2B 1863cf5848c45ef0a362c58a7169393e7d72dc88191e4ae1b5a8ef89a0cc37b9a6c70cf5b229c0879473a56d5026d29cea98eb4493f967ff54694f0d827b3f0d SHA512 99bc4616a041161a9c97141b8b2654ebee95a3134a22c6961be2c2da282758711b2375df6e21b4103d4a55a2b1d5b4f8a1610ea4998ebee2846890e2a579b981
+EBUILD sympy-1.14.0_rc1.ebuild 2012 BLAKE2B f2b9ec220c88997577f00d4896b02ac5b01cc280736cef582a6c93ff40fe4f9997400e1405b429da2ea2db344f12ca6c2368d7b1f3e1e0fe167932a29e212614 SHA512 5b1e8f863319148561088bf7c25416ea05007d74e3ecad5e6d81e886902f68c8b9b50a73bdac79c190ff7496c362cfec6d123eb1983f5973b6c0250d9f810b75
MISC metadata.xml 1639 BLAKE2B b539888e4658c640442db1cb6bd6561664ee6c50109926d69572f4e2cfcdbef230a56909e799b09b860a8688ce66455ae5c5ac86099893ba667feb0198f65abe SHA512 9ba4c310c759e9e7fa3a726850b342e79ed07e4ab369ad126a35b1741fd4d343ba75af457cfcd76c5539b3259e0eb198fb58ae965c231bb38a94c83c00f52e48
diff --git a/dev-python/sympy/sympy-1.14.0_rc1.ebuild b/dev-python/sympy/sympy-1.14.0_rc1.ebuild
new file mode 100644
index 000000000000..ec67abc046c1
--- /dev/null
+++ b/dev-python/sympy/sympy-1.14.0_rc1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="
+ https://www.sympy.org/
+ https://github.com/sympy/sympy/
+ https://pypi.org/project/sympy/
+"
+# pypi sdist misses some files, notably top-level conftest.py, as of 1.12.1_rc1
+SRC_URI="
+ https://github.com/sympy/sympy/archive/${PV/_/}.tar.gz
+ -> ${P/_/}.gh.tar.gz
+"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="imaging ipython latex mathml pdf png pyglet symengine texmacs"
+
+RDEPEND="
+ >=dev-python/mpmath-1.1.0[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require old version of antlr4, also deprecated
+ # https://github.com/sympy/sympy/issues/27026
+ sympy/parsing/tests/test_autolev.py
+ sympy/parsing/tests/test_latex.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --veryquickcheck ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}