summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
commit517343fddd94e620e94be97ae22eca4b57dc7625 (patch)
tree70b62f663c2d6f154c8808e55e827c69509918bd /dev-python/sympy
parent6554f04b9a44e1ffe5d2f614201c11deed2703bd (diff)
gentoo auto-resync : 18:02:2023 - 02:09:39
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch54
-rw-r--r--dev-python/sympy/sympy-1.11.1-r1.ebuild70
3 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index bb75a9b4230d..457714998a05 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
+AUX sympy-1.11-no-deprecated-threading-event-api.patch 1985 BLAKE2B bed11566b12fb49e7f52d176d536b15872a1b7cf8e570c17a068126f38cdf13f1d94d8f6c2d74e086d9e6c4ecfc6498613318f4e2f9f8a261224f1cc8bb4b908 SHA512 5df7337eb1c4bdc66b30a5a6db9047a9ed590fdcd7fb7cbc82a4c7342c4d2d047cbfd8549748ea3e0e4db8dc6e1ad97984fca87d85489dffe78599f7e2e29745
DIST sympy-1.11.1.gh.tar.gz 13462495 BLAKE2B a45320d087057595d3574490c6dc07bcdf7870543e9adcbaca9abe293d84875c123bbc91a7263a87b0b71568dece4e1304b6bf76f60ae64e353520f0ca686b1f SHA512 6cc720b673cf31a2e8f56a5cae24ec15024ea43dee92196adb0a87f28561b5d2404fbbfd3d55a8414930a31d4d0f4a731d458ad528c8cbb03c37555f5c14ce4a
+EBUILD sympy-1.11.1-r1.ebuild 1808 BLAKE2B 4303cc7acd257733707711ece0886dccf48c73fffb9f953be320b0322f1fd820372f43da89e37ef12cb0854e38e1f522ff8d5c59a971bcf3f87bf345d3981f4b SHA512 c3b279aa371b1751cba7e59a991dadda8306701f2a9d24025a3e04dbf0b31eb314491a1cc58e4f12c525ecc320f783f99d940015b860ad47df10a2290f22774c
EBUILD sympy-1.11.1.ebuild 1686 BLAKE2B a2f2b3bf4de552715033b9e0944a5b5c21b3c2bc35c216a097264b7e60f3b71eaf90eb754be662862d1b91b3f5fa01cc64954cee02a5c94ba61eaeeb75e26d25 SHA512 b239558442e8bb7b41dfd2fde26ccefc2a041fb228e1c89f64e833be222f340066350293d3353c2ea5c63f77fc2a71cd40f073f278f6c6a4762b3449a228eb01
MISC metadata.xml 1722 BLAKE2B 09837a8e4ed0d70cf62a2e5028d480ffd7d15d821220c771dec04380e9707da56625651a49ac656a7de27ee3e8f395091abe763d2d3c59cfe32bf363cdba60cf SHA512 fad83c852dd953709e20056b0da38a0f0504bc70a99d9a9fbf295d98ed462811ee6fcf755d5ad1aeb515fd62fafe35a609f6d2892af2ed921870b6f5c38edc5f
diff --git a/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch b/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch
new file mode 100644
index 000000000000..eaffd3f1fbe1
--- /dev/null
+++ b/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch
@@ -0,0 +1,54 @@
+Patch back-ported from the sympy git repo
+url: https://github.com/sympy/sympy/commit/b89ca436cf25e2a1caf82c9d33221d06698d0ff5
+
+commit b89ca436cf25e2a1caf82c9d33221d06698d0ff5
+Author: Chris Kerr <chris.kerr@mykolab.ch>
+Date: Thu Sep 22 19:32:27 2022 +0300
+
+ Replace deprecated .isSet() method with .is_set()
+
+ Fixes https://github.com/sympy/sympy/issues/24074
+
+diff --git a/sympy/plotting/pygletplot/plot_mode_base.py b/sympy/plotting/pygletplot/plot_mode_base.py
+index c1c2b0a6ec..2c6503650a 100644
+--- a/sympy/plotting/pygletplot/plot_mode_base.py
++++ b/sympy/plotting/pygletplot/plot_mode_base.py
+@@ -269,7 +269,7 @@ def _calculate_all(self):
+ self._calculate_cverts()
+
+ def _calculate_verts(self):
+- if self._calculating_verts.isSet():
++ if self._calculating_verts.is_set():
+ return
+ self._calculating_verts.set()
+ try:
+@@ -280,9 +280,9 @@ def _calculate_verts(self):
+ self.bounds_callback()
+
+ def _calculate_cverts(self):
+- if self._calculating_verts.isSet():
++ if self._calculating_verts.is_set():
+ return
+- while self._calculating_cverts.isSet():
++ while self._calculating_cverts.is_set():
+ sleep(0) # wait for previous calculation
+ self._calculating_cverts.set()
+ try:
+@@ -291,7 +291,7 @@ def _calculate_cverts(self):
+ self._calculating_cverts.clear()
+
+ def _get_calculating_verts(self):
+- return self._calculating_verts.isSet()
++ return self._calculating_verts.is_set()
+
+ def _get_calculating_verts_pos(self):
+ return self._calculating_verts_pos
+@@ -300,7 +300,7 @@ def _get_calculating_verts_len(self):
+ return self._calculating_verts_len
+
+ def _get_calculating_cverts(self):
+- return self._calculating_cverts.isSet()
++ return self._calculating_cverts.is_set()
+
+ def _get_calculating_cverts_pos(self):
+ return self._calculating_cverts_pos
diff --git a/dev-python/sympy/sympy-1.11.1-r1.ebuild b/dev-python/sympy/sympy-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..df5b5e24a757
--- /dev/null
+++ b/dev-python/sympy/sympy-1.11.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://www.sympy.org/"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
+
+RDEPEND="
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ aesara? ( $(python_gen_cond_dep 'dev-python/aesara[${PYTHON_USEDEP}]' python3_{9..10}) )
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.11-no-deprecated-threading-event-api.patch"
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}