summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/sympy
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.10.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index a0ad883f0a00..e2c00f600ded 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
+DIST sympy-1.10.tar.gz 7665598 BLAKE2B 423c501cbdec9369b094156ec4c06c38e52daa0824f61fc2d57b0002473428c7b2df59156bd129c07ea57bb712577568b014b1b48ff0a1d1555ccf25d2fe01df SHA512 0107c68b38809fbcec597339447fa830a9cb3c55863799c41dfb5d122ac7564fdf7c685fe2eedaaa3b8d5c9160b196ef2484fff4c7e99aa17a5a562f3fb73be5
DIST sympy-1.9.tar.gz 7476018 BLAKE2B 5ab9920bf6d16eaed3af30100e7593551a4dce29dc76605ccf87d55e8a7c14514b5733c9456353403cfc96008fd5d046ce04f44bb7e69f844d545bdd3e55e7e0 SHA512 139712219ba6bf420ba89b3f8d086ab8883c5ab965e9308ba9ee665ac3ac69a9b16fa30c6f5dfbc77dd34873ff3ff95c0d058954d7f9d853f5e9537efc24dd3c
+EBUILD sympy-1.10.ebuild 1630 BLAKE2B 1a8e852035e42e4588f3d23ba1a9c0fe5a2b70364469a8828f1fad51588a77f6cb2a0bd1bbd02cdb28835d3410f0ead84edb5f77f2f5a8a27c1e6e7fd1046e8d SHA512 4e0d685d362b2dbb92416d2205200a1f0c331f5f4dc93e931878a6e228f288c790062ec950f11790453e3f5da6a3281e65a479b1dab8abf955395949a40e0e9e
EBUILD sympy-1.9.ebuild 1597 BLAKE2B 871fbfdbd86916c14c7f7d691f6e41057ddb4e23ae7e7ae2142902b55698633e03e10609979de58cb682d000d0ec3cd73f469b57b1e2e9d6ba41857e9060b208 SHA512 6b361907c76f58f4e488e3111585f4a30d9e464170ab3595cbffe05638311a28f919b0e07b8d3bf1255f8733f8b55ffa1c8b160575387f8cfc98600911b26e89
MISC metadata.xml 1715 BLAKE2B 8e7464f09c9d4b88e448c70a041ee1c3693587dffacf697ec6c13c069b90973f6be1e0f50fa40ebe9b12e7a33f1bf21e175e445563ea639bfb2a96dcae5ab96a SHA512 f5baf2997f559dee17355a7612b479dbd13048376f2bb2b26401150502d59eaf500066880379d9bbbe4ee7ba29e99821a27067d2e2df284bbfda9fb99058b23c
diff --git a/dev-python/sympy/sympy-1.10.ebuild b/dev-python/sympy/sympy-1.10.ebuild
new file mode 100644
index 000000000000..19863d7a5055
--- /dev/null
+++ b/dev-python/sympy/sympy-1.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://www.sympy.org/"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
+
+RDEPEND="
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ aesara? ( dev-python/aesara[${PYTHON_USEDEP}] )
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}