summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/sympy
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest4
-rw-r--r--dev-python/sympy/metadata.xml4
-rw-r--r--dev-python/sympy/sympy-1.8.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 8c870435ea13..47cb4ae252c2 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,5 @@
DIST sympy-1.7.1.tar.gz 6974183 BLAKE2B 4bd8c9d60c46b05a7fc6c622667858fe17d25798756dbe967ce19abc8047263fe540f332e39418e877852c0565270377bd01fea7e65aa35ed4e03079bc130805 SHA512 eb9387bb9c632203af650279f896427556725b7496c00d8dfe97b7476beedbbee5714659f7fb44b4fa986c9567cdcaefcc19401d63e1ca0e9a6c7317855440ea
+DIST sympy-1.8.tar.gz 7167842 BLAKE2B 878c6daf0584c9da54f82b9c68c62715792db428ab4ebfb355f0368c52edb254947d1ce1919e651279b767295ecb00a76b8cbbaa1fbe9c97915221c7403c3ded SHA512 61141e1d0a6105e725fb415edbdf981b3aa95debcfe73f9da5ca36afc7a70e91b5c28ed45454054c1b9a8d45e42bfe724e5b20da717746c301fd095da17f4db7
EBUILD sympy-1.7.1-r1.ebuild 1847 BLAKE2B 6de0bc9fd9c65680f2f1208eafd20a3d94d8ca9658b1508efefaa834ec60bdd829ddbb4cb7af36d59958e39c54dedc58aff6d58e7f4101f1c7ea4a7ece39b5f0 SHA512 ede543165181565b24379c9a060293f4ed4282ec2f734587d1be857c0ddb81b5fc9aa3ca9961843bdf0da215aece84949eea1f07ddc46b1027a67f3db3194ee9
-MISC metadata.xml 1607 BLAKE2B cb7e15ad95ed4b47eff7399fe726815cf66ef40bf0af31f31d423aa808bc4f3386756e2a8e98fdf584113d6923edb47a91f39effb08013b5865608e2ca29f3b4 SHA512 198aa6343d446bb348a827b48097055ad709bb6bba22cf9bc3eca9d28fd71d450acad47bfa14fce403dd5d4bbff584bd78407f3859ea4aef918e4768af685c7e
+EBUILD sympy-1.8.ebuild 1624 BLAKE2B 03a391816be810d7c99dde9bc31fa82f0008f55a3b8a579253f4e3b28cacc309ddf76a325d0e7fea783c09df9f1391dbc259c8d3fdaa78580b0096059f5e8665 SHA512 f0a28e0e8eddc83ac345fce02042a027292de8c7a18cb12b87ca25e992b46c0495aedd0ae038e9bd2565ef4dc468c0fde38d5f3df8fcc1ad5e3c59ba2ed95c77
+MISC metadata.xml 1714 BLAKE2B c3f014cb556c1bc6de0d2d153d3bcd768f7529bd84a78560943118007faa6cba2aaef0543d4eafd9089789f9c0ca25a4cb4cd77f475799fc3726104e73e560bf SHA512 e46a7c8c36e0fdad39bd458f21a0b9ecc5bab84fb54931914ee131ac869b11069fa2692bf7eeae4edc4d0b42e0537cc53088c78f4ab286773b1fb896a5293cce
diff --git a/dev-python/sympy/metadata.xml b/dev-python/sympy/metadata.xml
index f1df7f4f9185..fb045e709cd2 100644
--- a/dev-python/sympy/metadata.xml
+++ b/dev-python/sympy/metadata.xml
@@ -13,6 +13,10 @@
<email>sci-mathematics@gentoo.org</email>
<name>Gentoo Mathematics Project</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<longdescription>
SymPy is a Python library for symbolic mathematics (manipulation). It
aims to become a full-featured computer algebra system (CAS) while keeping
diff --git a/dev-python/sympy/sympy-1.8.ebuild b/dev-python/sympy/sympy-1.8.ebuild
new file mode 100644
index 000000000000..727e2d95fbc8
--- /dev/null
+++ b/dev-python/sympy/sympy-1.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://www.sympy.org/"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+
+RDEPEND="
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+ theano? ( dev-python/aesara[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}