summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 07:41:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 07:41:16 +0000
commit3e3aa158fd100df495010eed7915f012d5c9bcaa (patch)
treeeec12007aef38a8d8dbffd66d0e186f005fdc65c /dev-python/sympy
parent4560e1a95e1072b051371c59aec78b15e4787ded (diff)
gentoo auto-resync : 24:12:2023 - 07:41:16
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.12.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 7978dd66b3c8..e95ea8abc2bc 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -2,5 +2,4 @@ AUX sympy-1.12-c99.patch 1666 BLAKE2B 3b60410c635cd55935108776e827cca2cafc2b16b2
AUX sympy-1.12-py312.patch 1543 BLAKE2B 786e7f2934adf9d30c21f5fa807910507bddebbffc2c2d91a80e48b9767d340490f459df08a61c2b9f7d5d48342a24ac2c40673ed63a531d0c83ddea1773985c SHA512 e6359b32f9949b8412e9af1183e7cf2c7e888a83a15876f0fb370a3e671b993ef0b524e103aa6eff29e11a33b0ce44fc8e3d2e53c61042924130738678188bab
DIST sympy-1.12.gh.tar.gz 7212937 BLAKE2B 1d37a019e7a6700e69e16d6ca7fdc563711165fc226ac6ec745d20fa6dc689ee9ea01a92549d851aacff763230872c2d1d0cb5bde581c4f960f5de515ffb5f06 SHA512 96a89b88f6912d70c56f5bd1903dd3c518963118ff25d033cdcb7da2f260b8ee209d3ab4a4394dd2b5dc0b4585b71ccd55d55c8e5c6e28024cccbedf07ee4360
EBUILD sympy-1.12-r1.ebuild 3227 BLAKE2B 61098074c5ae664a5a6185ae4bfb1ee4e6bb5d40a8ebb02487419a096d57826a04aad64542b0660b6bc76ad9c7d6a949bef29c88ca9d55144ae5ce79339f309f SHA512 d1814458cc2b462fb20baf9cb00e1720e224df5b2ef1dd68de1815c64223e73f6e14b647a5cdbf2a3d93b996c1d7eb83a38ae73cf8b42156ceb95e0d15735aa6
-EBUILD sympy-1.12.ebuild 3191 BLAKE2B 128a3e1077d22fb5b10f1ef98ac7110f4a795aa619e77e81a92baec02cc9de10d9af808b5d264634ca5870ff5e5134e37fdfd515166f9bbf2bd0944308bfefc4 SHA512 6b4f8413246d003ce4053b17f3b2e02296ee940678e7b6bda016b57d9c73ccd11ad39f5cac150fc958a8556db0f5de99aefdfab4a483bf7456f56055a224c485
MISC metadata.xml 1722 BLAKE2B 09837a8e4ed0d70cf62a2e5028d480ffd7d15d821220c771dec04380e9707da56625651a49ac656a7de27ee3e8f395091abe763d2d3c59cfe32bf363cdba60cf SHA512 fad83c852dd953709e20056b0da38a0f0504bc70a99d9a9fbf295d98ed462811ee6fcf755d5ad1aeb515fd62fafe35a609f6d2892af2ed921870b6f5c38edc5f
diff --git a/dev-python/sympy/sympy-1.12.ebuild b/dev-python/sympy/sympy-1.12.ebuild
deleted file mode 100644
index 7f16aaf566bb..000000000000
--- a/dev-python/sympy/sympy-1.12.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="
- https://www.sympy.org/
- https://github.com/sympy/sympy/
- https://pypi.org/project/sympy/
-"
-SRC_URI="
- https://github.com/sympy/sympy/archive/${P}.tar.gz -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine texmacs"
-
-RDEPEND="
- dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- aesara? (
- $(python_gen_cond_dep '
- dev-python/aesara[${PYTHON_USEDEP}]
- ' python3_{10..11})
- )
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-py312.patch"
-)
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # require old version of antlr4
- sympy/parsing/tests/test_autolev.py
- sympy/parsing/tests/test_latex.py
- # crash due to assertions in sys-devel/llvm[debug]
- sympy/parsing/tests/test_c_parser.py
-
- # TODO: pytest?
- sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_check
- sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_dsolve_dotprodsimp
-
- # either very slow or hanging
- sympy/solvers/ode/tests/test_systems.py::test_linear_new_order1_type2_de_lorentz_slow_check
- sympy/integrals/tests/test_failing_integrals.py::test_issue_15227
- sympy/matrices/tests/test_matrices.py::test_pinv_rank_deficient_when_diagonalization_fails
- sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type1
- sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
- )
-
- case ${EPYTHON} in
- pypy3)
- if has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
- has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
- then
- EPYTEST_DESELECT+=(
- # https://foss.heptapod.net/pypy/pypy/-/issues/4032
- sympy/tensor/array/tests/test_array_comprehension.py::test_arraycomprehensionmap
- )
- fi
- ;;
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest --veryquickcheck ||
- die -n "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.md )
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}