summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/sympy
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest4
-rw-r--r--dev-python/sympy/sympy-1.6.1.ebuild65
-rw-r--r--dev-python/sympy/sympy-1.6.2.ebuild65
3 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index dfe365ef05df..f95783c72669 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,7 @@
DIST sympy-1.5.1.tar.gz 6815997 BLAKE2B bc74d01fdf2ccea6b83a06c11f810e3d105e9d35b397c8b87a1bcc4e316d00c456f576baf57d1b4a6175e056dec58f05fbb05893519775ffa252ac018452d2ff SHA512 3c4220243d2cbcff9eedb2a7986431b5b4d7d0007c78208a60b21830c9a3528d2171086874c42205c1227f779e44c19b9562943e2935d329bc352e7ea85396c7
+DIST sympy-1.6.1.tar.gz 6811393 BLAKE2B cd19946fc726b5a74f9ff0af07f07f8f76ea28b20818653d785848e331c126d634d8167e3506d8b87c12ed057df4a59551f0a0214b7d1292e199c6a3353f70be SHA512 95630b6fad1e41f2d58d1f4f4433ef76d4553f3e119bfdd36048c5880ac7f07d572e901eaae0b5c6208f598989a86ab5e03932a851f8048c584154973be6982c
+DIST sympy-1.6.2.tar.gz 6811705 BLAKE2B 4cd894d28bedc986acc8ef67aa60f82e0899c2ed028658a8f340d7538b890e0ed380b3614a464eb58d71873b29b0795508b4556bb8115bf0c108336ef1e4cca3 SHA512 e16a1d85aba438e4248bac48a163ea1827e2cee57c28f7670ed19cc69d4c08d6796d62f79d245e269d75765b8f7ff4f4ca2841f98534e136ceeb5d3f7a5d252a
EBUILD sympy-1.5.1-r1.ebuild 1850 BLAKE2B e2f08e54dca354747252fbe8746a163b93731a54c3bd2da1b8bced7ed8a3a94185eef5d3c5d7c71a7cf00dc8eed8b041253a451acb682eb3ace923a20df442b7 SHA512 fdc6a748fe63dac5f904b36ea51beaddecbd074ff1ae9497e0cf30481d505d0d48eea9732342f9033aed6d24a740aaf3f9f53586514f4fc2c3e89db111813a98
+EBUILD sympy-1.6.1.ebuild 1770 BLAKE2B d6099d50f37f0bbf766b3f4f5ccacb1f98ec13bd28cbb2034df2a676a9ccb3c36b56199afd4d4b2242ac1386c93b73db5bbb9569eeeac62ba176d214f86acf89 SHA512 9fa463c7de1d7e7622e9cb2d97750d9a9da55ab187a4a5bc3adb92dc40da90c518d495f2d743c10a759e146e1adf93a8389aa33e05971812d57879503ccc6444
+EBUILD sympy-1.6.2.ebuild 1770 BLAKE2B d6099d50f37f0bbf766b3f4f5ccacb1f98ec13bd28cbb2034df2a676a9ccb3c36b56199afd4d4b2242ac1386c93b73db5bbb9569eeeac62ba176d214f86acf89 SHA512 9fa463c7de1d7e7622e9cb2d97750d9a9da55ab187a4a5bc3adb92dc40da90c518d495f2d743c10a759e146e1adf93a8389aa33e05971812d57879503ccc6444
MISC metadata.xml 1476 BLAKE2B d6a0d7816ae7c0c2d61d6f584b9c872d0169053d43bb604f66ff242721df6f74788ade3de06b23db53239dc0da1182beda16c86eb7e7b383fb0964b13eca1883 SHA512 99d6eb86839fd09abd4db55783e028c6f97c9d0dfa8d68ceda881e6ca981f86877e55a0a83d34b432833f0824a896eea8af35eb9ea499bffe0c62e1e0a27c3c2
diff --git a/dev-python/sympy/sympy-1.6.1.ebuild b/dev-python/sympy/sympy-1.6.1.ebuild
new file mode 100644
index 000000000000..adb5f1ab365b
--- /dev/null
+++ b/dev-python/sympy/sympy-1.6.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 eutils virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://sympy.org"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+ theano? ( dev-python/theano[${PYTHON_USEDEP}] )
+"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" setup.py test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}
diff --git a/dev-python/sympy/sympy-1.6.2.ebuild b/dev-python/sympy/sympy-1.6.2.ebuild
new file mode 100644
index 000000000000..adb5f1ab365b
--- /dev/null
+++ b/dev-python/sympy/sympy-1.6.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 eutils virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://sympy.org"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+ theano? ( dev-python/theano[${PYTHON_USEDEP}] )
+"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" setup.py test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}