summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-17 10:58:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-17 10:58:21 +0000
commit27cf8f197a427c1c71255f86149344e3bf1be47d (patch)
tree9e2b0e686362a4d009c515b9ecda0c33a4ecad30 /dev-python/sympy
parent04a96556dc0036655ac429edf598cc48febe294b (diff)
gentoo auto-resync : 17:11:2023 - 10:58:21
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest3
-rw-r--r--dev-python/sympy/files/sympy-1.12-py312.patch42
-rw-r--r--dev-python/sympy/sympy-1.12.ebuild32
3 files changed, 73 insertions, 4 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 4b532f6450af..2956531cfd58 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,4 @@
+AUX sympy-1.12-py312.patch 1543 BLAKE2B 786e7f2934adf9d30c21f5fa807910507bddebbffc2c2d91a80e48b9767d340490f459df08a61c2b9f7d5d48342a24ac2c40673ed63a531d0c83ddea1773985c SHA512 e6359b32f9949b8412e9af1183e7cf2c7e888a83a15876f0fb370a3e671b993ef0b524e103aa6eff29e11a33b0ce44fc8e3d2e53c61042924130738678188bab
DIST sympy-1.12.gh.tar.gz 7212937 BLAKE2B 1d37a019e7a6700e69e16d6ca7fdc563711165fc226ac6ec745d20fa6dc689ee9ea01a92549d851aacff763230872c2d1d0cb5bde581c4f960f5de515ffb5f06 SHA512 96a89b88f6912d70c56f5bd1903dd3c518963118ff25d033cdcb7da2f260b8ee209d3ab4a4394dd2b5dc0b4585b71ccd55d55c8e5c6e28024cccbedf07ee4360
-EBUILD sympy-1.12.ebuild 1815 BLAKE2B 434c650b73aef7e8b8fcc6d25da4c046ffabfc46c0301f27b55cb752cdb67daa26bcc922a5c0955bd73bef97d4d6afdce4b6d27221e4fbda1406ee8356cbd336 SHA512 1e1e2966d89efbb9b5f1e3253afdca7633c12b8f1d66b6f68a069d903c19d5e94aba316bd6b3e14bee93eb6069c25f66e8aed8e17f260c9d0c893aa0fd5bb71c
+EBUILD sympy-1.12.ebuild 2842 BLAKE2B 91b5c52aad0ee39d936a0da3016aded9435c90c36172f2840018a5faa04e4f5d56c6f141ee93e227b6e7067eb5340acd92489f9daa67bd7a836ebd50cf7a68ac SHA512 92771946b81e53949731182cfd5aeb5be62308444917543fecb8a26745da95eac85384648e41ece5000d80c82e547739c05ae13acf6f101e3ea6bd5b2f1dee88
MISC metadata.xml 1722 BLAKE2B 09837a8e4ed0d70cf62a2e5028d480ffd7d15d821220c771dec04380e9707da56625651a49ac656a7de27ee3e8f395091abe763d2d3c59cfe32bf363cdba60cf SHA512 fad83c852dd953709e20056b0da38a0f0504bc70a99d9a9fbf295d98ed462811ee6fcf755d5ad1aeb515fd62fafe35a609f6d2892af2ed921870b6f5c38edc5f
diff --git a/dev-python/sympy/files/sympy-1.12-py312.patch b/dev-python/sympy/files/sympy-1.12-py312.patch
new file mode 100644
index 000000000000..13501c3fb34d
--- /dev/null
+++ b/dev-python/sympy/files/sympy-1.12-py312.patch
@@ -0,0 +1,42 @@
+From 8a2c3c4de266f49312eda4c91dcdf5d5464717e8 Mon Sep 17 00:00:00 2001
+From: Pablo Galindo <pablogsal@gmail.com>
+Date: Fri, 9 Jun 2023 11:22:20 +0100
+Subject: [PATCH] Fix factorial parsing for Python 3.12
+
+Signed-off-by: Pablo Galindo <pablogsal@gmail.com>
+---
+ .mailmap | 1 +
+ sympy/parsing/sympy_parser.py | 5 ++++-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/.mailmap b/.mailmap
+index fe496637dd..8a9de2d99d 100644
+--- a/.mailmap
++++ b/.mailmap
+@@ -1496,6 +1496,7 @@ naelsondouglas <naelson17@gmail.com>
+ noam simcha finkelstein <noam.finkelstein@protonmail.com>
+ numbermaniac <5206120+numbermaniac@users.noreply.github.com>
+ oittaa <8972248+oittaa@users.noreply.github.com>
++pablogsal <pablogsal@gmail.com>
+ pekochun <hamburg_hamburger2000@yahoo.co.jp>
+ prshnt19 <prashant.rawat216@gmail.com>
+ rahuldan <rahul02013@gmail.com>
+diff --git a/sympy/parsing/sympy_parser.py b/sympy/parsing/sympy_parser.py
+index 5935f4baf2..862679e644 100644
+--- a/sympy/parsing/sympy_parser.py
++++ b/sympy/parsing/sympy_parser.py
+@@ -627,7 +627,10 @@ def factorial_notation(tokens: List[TOKEN], local_dict: DICT, global_dict: DICT)
+ result: List[TOKEN] = []
+ nfactorial = 0
+ for toknum, tokval in tokens:
+- if toknum == ERRORTOKEN:
++ if toknum == OP and tokval == "!":
++ # In Python 3.12 "!" are OP instead of ERRORTOKEN
++ nfactorial += 1
++ elif toknum == ERRORTOKEN:
+ op = tokval
+ if op == '!':
+ nfactorial += 1
+--
+2.42.1
+
diff --git a/dev-python/sympy/sympy-1.12.ebuild b/dev-python/sympy/sympy-1.12.ebuild
index 8924c8a9f617..588e766d8a3a 100644
--- a/dev-python/sympy/sympy-1.12.ebuild
+++ b/dev-python/sympy/sympy-1.12.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 virtualx
@@ -22,7 +22,7 @@ S="${WORKDIR}/${PN}-${P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
+IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine texmacs"
RDEPEND="
dev-python/mpmath[${PYTHON_USEDEP}]
@@ -47,14 +47,40 @@ RDEPEND="
texmacs? ( app-office/texmacs )
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
src_test() {
virtx distutils-r1_src_test
}
python_test() {
- esetup.py test
+ local EPYTEST_DESELECT=(
+ # require old version of antlr4
+ sympy/parsing/tests/test_autolev.py
+ sympy/parsing/tests/test_latex.py
+ # crash due to assertions in sys-devel/llvm[debug]
+ sympy/parsing/tests/test_c_parser.py
+
+ # TODO: pytest?
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_check
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_dsolve_dotprodsimp
+
+ # either very slow or hanging
+ sympy/solvers/ode/tests/test_systems.py::test_linear_new_order1_type2_de_lorentz_slow_check
+ sympy/integrals/tests/test_failing_integrals.py::test_issue_15227
+ sympy/matrices/tests/test_matrices.py::test_pinv_rank_deficient_when_diagonalization_fails
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type1
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --veryquickcheck ||
+ die -n "Tests failed with ${EPYTHON}"
}
python_install_all() {