summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-23 00:06:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-23 00:06:15 +0100
commit0e1abc96fea41c994e56391bd01c5c9298236783 (patch)
tree53f4297b17f44131f819fb0ae2ce606dc7121108 /dev-python/sympy
parentcf59cc78468c9bcfef9e16b7b27c115896d805fd (diff)
gentoo auto-resync : 23:04:2023 - 00:06:15
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.11.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 567d5271dc0c..53240be4ee10 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,5 +1,4 @@
AUX sympy-1.11-no-deprecated-threading-event-api.patch 1985 BLAKE2B bed11566b12fb49e7f52d176d536b15872a1b7cf8e570c17a068126f38cdf13f1d94d8f6c2d74e086d9e6c4ecfc6498613318f4e2f9f8a261224f1cc8bb4b908 SHA512 5df7337eb1c4bdc66b30a5a6db9047a9ed590fdcd7fb7cbc82a4c7342c4d2d047cbfd8549748ea3e0e4db8dc6e1ad97984fca87d85489dffe78599f7e2e29745
DIST sympy-1.11.1.gh.tar.gz 13462495 BLAKE2B a45320d087057595d3574490c6dc07bcdf7870543e9adcbaca9abe293d84875c123bbc91a7263a87b0b71568dece4e1304b6bf76f60ae64e353520f0ca686b1f SHA512 6cc720b673cf31a2e8f56a5cae24ec15024ea43dee92196adb0a87f28561b5d2404fbbfd3d55a8414930a31d4d0f4a731d458ad528c8cbb03c37555f5c14ce4a
EBUILD sympy-1.11.1-r2.ebuild 1810 BLAKE2B 6c2682ebccdb3083351cd1e5f6d16ec0f02e64b63e859a063e28a07679aee1582b316458e55b58d5e6217e345e203f29a952efd8600a7a49b00c26f011d41bc1 SHA512 a912f80b41cd68c9b5d21548d2c1f134e374b5dd820577cd2a43e5bcef59e124c10f12016ee18cdca5caa0cc18f492ec776e01697b4b643863682aed51d3880e
-EBUILD sympy-1.11.1.ebuild 1686 BLAKE2B a2f2b3bf4de552715033b9e0944a5b5c21b3c2bc35c216a097264b7e60f3b71eaf90eb754be662862d1b91b3f5fa01cc64954cee02a5c94ba61eaeeb75e26d25 SHA512 b239558442e8bb7b41dfd2fde26ccefc2a041fb228e1c89f64e833be222f340066350293d3353c2ea5c63f77fc2a71cd40f073f278f6c6a4762b3449a228eb01
MISC metadata.xml 1722 BLAKE2B 09837a8e4ed0d70cf62a2e5028d480ffd7d15d821220c771dec04380e9707da56625651a49ac656a7de27ee3e8f395091abe763d2d3c59cfe32bf363cdba60cf SHA512 fad83c852dd953709e20056b0da38a0f0504bc70a99d9a9fbf295d98ed462811ee6fcf755d5ad1aeb515fd62fafe35a609f6d2892af2ed921870b6f5c38edc5f
diff --git a/dev-python/sympy/sympy-1.11.1.ebuild b/dev-python/sympy/sympy-1.11.1.ebuild
deleted file mode 100644
index abc403f75124..000000000000
--- a/dev-python/sympy/sympy-1.11.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://www.sympy.org/"
-SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
-
-RDEPEND="
- dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- aesara? ( dev-python/aesara[${PYTHON_USEDEP}] )
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.md )
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}