summaryrefslogtreecommitdiff
path: root/dev-python/sympy/sympy-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/sympy/sympy-1.0-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/sympy/sympy-1.0-r1.ebuild')
-rw-r--r--dev-python/sympy/sympy-1.0-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/sympy/sympy-1.0-r1.ebuild b/dev-python/sympy/sympy-1.0-r1.ebuild
deleted file mode 100644
index a1b4f8b591ef..000000000000
--- a/dev-python/sympy/sympy-1.0-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1 eutils virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://sympy.org"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples gtk imaging ipython latex mathml opengl pdf png test texmacs"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ipython? ( || ( $(python_gen_useflags -3) ) )"
-
-RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? (
- dev-libs/libxml2:2[${PYTHON_USEDEP}]
- gtk? ( x11-libs/gtkmathview[gtk] )
- )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
-"
-
-DEPEND="${RDEPEND}
- test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- epatch "${FILESDIR}"/${P}-doc-makefile.patch
- epatch "${FILESDIR}"/${P}-zeta.patch
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- PYTHONPATH="." distutils-r1_python_compile
-}
-
-python_test() {
- virtx "${PYTHON}" setup.py test
-}
-
-python_install() {
- PYTHONPATH="." distutils-r1_python_install
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}