summaryrefslogtreecommitdiff
path: root/dev-python/symengine/symengine-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/symengine/symengine-0.5.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/symengine/symengine-0.5.1.ebuild')
-rw-r--r--dev-python/symengine/symengine-0.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/symengine/symengine-0.5.1.ebuild b/dev-python/symengine/symengine-0.5.1.ebuild
new file mode 100644
index 000000000000..531654017bce
--- /dev/null
+++ b/dev-python/symengine/symengine-0.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit distutils-r1
+
+MYP=${PN}.py-${PV}
+
+DESCRIPTION="Python wrappers to the symengine C++ library"
+HOMEPAGE="https://github.com/symengine/symengine.py"
+SRC_URI="https://github.com/symengine/symengine.py/archive/v${PV}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/symengine-0.4"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ cd "${BUILD_DIR}"
+ nosetests -v || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_prepare_all
+ rm "${ED}"/usr/share/doc/${PF}/README.md || die
+ newdoc README.md ${PN}.py.md
+}