summaryrefslogtreecommitdiff
path: root/dev-python/symboltype/symboltype-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/symboltype/symboltype-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/symboltype/symboltype-1.0.ebuild')
-rw-r--r--dev-python/symboltype/symboltype-1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/symboltype/symboltype-1.0.ebuild b/dev-python/symboltype/symboltype-1.0.ebuild
new file mode 100644
index 000000000000..ea4b34c262de
--- /dev/null
+++ b/dev-python/symboltype/symboltype-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="SymbolType"
+
+DESCRIPTION="Gives access to the peak.util.symbols module"
+HOMEPAGE=" http://peak.telecommunity.com/DevCenter/SymbolType https://pypi.python.org/pypi/SymbolType"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip -> ${P}.zip"
+
+KEYWORDS="amd64 x86"
+IUSE="doc"
+LICENSE="ZPL"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+python_test() {
+ "${PYTHON}" test_symbols.py && einfo "Tests passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+}