summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
commite3f21c8aff8a76afe3423721c437a088e9232840 (patch)
treefde2c1906a9787adec106c5d6b708cd60de02c60 /dev-python/sybil
parent1f00990debeffd0052c194989d0a02baac23eb96 (diff)
gentoo auto-resync : 23:04:2024 - 23:59:26
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-6.1.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 298e391b83ed..fa956a4737dc 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
+DIST sybil-6.1.0.gh.tar.gz 70823 BLAKE2B dfdd931f1f2bb7944a97ceb92425e55accc8d7587c829b65be9b6b65007f8a32b076938e1114bbee76d0a9592ba29335cf88e982aa00d1a3ad17c8523f162548 SHA512 2048073c8ef8a9c0f71dabe39ada1404eef3d83509fe3f3e0a7e6b5d1f65a24242c8faf14aaac9ea12b21ab5908dee9bae9d03d9907f09a830d73a3b6e52f8d3
EBUILD sybil-6.0.3.ebuild 838 BLAKE2B 746f0e8fe9be9f8cc81ac5d546db25fcf86af396073628f035dbc3815f3f49d6bff93f8fe0e0c4689282d9a323712c1550987173ab682d1166a9a6d0d80eeda1 SHA512 e47366e0f4ace127660b404c19116999efd0d9e8a04b93f56d56a7128612c35ef64e5b60053f08c560d476400196c37d9e93a11855980ec2638ce9cb8918b983
+EBUILD sybil-6.1.0.ebuild 841 BLAKE2B 94ebec0834adb47ad9452236d286d1e1624bc29e2f90b7bfd870d0f56faf10d93cb81cb15f66ff7abb89a4372e8b712cce0c65588d1aa743e108a75c3a9e328b SHA512 e0e851bf2fc6ac1f7bf301abbdcbe20ef69f0ddc45a3c6b4a4a2624f0f54f148a04c5474cd4ec946d3970fdb773044965ce9d252753ce90c6914664e418cf448
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-6.1.0.ebuild b/dev-python/sybil/sybil-6.1.0.ebuild
new file mode 100644
index 000000000000..adf69fd38724
--- /dev/null
+++ b/dev-python/sybil/sybil-6.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}