summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 05:48:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 05:48:38 +0000
commitd13aef5a4ce5eb3b31565d0d9e67e903e5e932df (patch)
treecf5b3316139fb245cc44995f3383cf931861d9fa /dev-python/sybil
parent262dea609d1cde1b7d3f556b5e77f6ba6f6d272b (diff)
gentoo auto-resync : 01:02:2024 - 05:48:38
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-6.0.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 525b2a28b542..9cca1387fc5d 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,4 +1,6 @@
AUX sybil-6.0.2-pytest-8.patch 2027 BLAKE2B c71742c315b0195a5984a40b399e071f648c9c5a688f3099d2a8771f01c946ae9074be307793055235225364330b72d7e00b27c03a3c94f0a56d316c60fc6b3a SHA512 f9c237aea2c498d3df076b011a377983344ad03b89e2f11146f13216d38157795f67f2afd78bf714ffbce2902d73caf1a79e01409738d92d8f3df4ee97761fa1
DIST sybil-6.0.2.gh.tar.gz 67619 BLAKE2B ec723cb21d2ac1232bd6e9a3e3edb0bc65c705048c2d288df778b4dd19a1b46c956f7d2bd57dfa028d7a8a06357501ffc1226ba171e2073abec51f8d3c536d86 SHA512 9966173b5fb013be1f298b586052d8c10b76efb43bf5230f3d0b780e6d6238e7e33840eeb7c8b9860911351ea612766ed19ea2a61d48424465f3b58e408da5d2
+DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
EBUILD sybil-6.0.2-r1.ebuild 901 BLAKE2B 559ec680a63f7a095b352808370bf04950ea23f683f0a4800a8dc3468a6c19f2ad5e90811daad2d60217b04a31c115782cafefc933e254b67acdb8f990ca682e SHA512 d58e428155a5727391159e7e500c405ab2705fcb93416127aad3360abaaa79ebadb64768a0568358bda4e1740cd46d873862c7301eb82673183a46c2ffe6ef79
+EBUILD sybil-6.0.3.ebuild 808 BLAKE2B a2deaf4582065c25a5e85f8e893f81c5b3afa9e90308097642e02050c647744373ec1f2e9e6d73694aa35c75b628b727ad997a176b74ed2826284db4d0c7e9a5 SHA512 ff51378e0b78d15eff40295c88562a4259e39f0e61cc36ef27d302b8652eef6cb4a8faae44f789ff9a4a1cb90f890b4a42a69af02e7fa2612de55fc090253543
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-6.0.3.ebuild b/dev-python/sybil/sybil-6.0.3.ebuild
new file mode 100644
index 000000000000..dfd594060e6f
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}