summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /dev-python/sybil
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-4.0.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 89dc06d766f9..b1b2a3f2cfbd 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-3.0.1.tar.gz 38265 BLAKE2B 3a9dd8d85a5a6228944f104d255826b4dfee80f5a349da3a0fa69edcfa0953145378f002c1bf834e21c0d382fc96a993b927bdc92bb3e9a84d34998ad6ade62f SHA512 312c57f0de646b1e7a3b992806362c1020b2d567c805d248e94ab22a336a8fc77704234e123e1ec74987bfea620b2f8c4d3714d32aee03587c615d3d90fe5558
+DIST sybil-4.0.0.gh.tar.gz 50845 BLAKE2B 5c7144ad1dd131f98c48f18cf6770782529a3c86a3f976461f032c9024ef93dc2de3c8bc327421a55a3f505982608e15cdcfe022f964c4fd871bd9de61205d68 SHA512 6cf0422ba856a85ba5dd105481cb2d06eb2ff196aee263a36e7ab44c7d45185df022bd859afc92b3b42dc418142e441f377adda82c0b5b0d1410697b563db994
EBUILD sybil-3.0.1.ebuild 466 BLAKE2B e7f8d067705ef95e0c0de18dd57bdfe732db6641fdd598f75c94bbfd1db07b4a3f1a6f48dceca424605f00b4191097a6195fe72d98176639a738536fa9fea31e SHA512 eb28765e157618a19e335787ec52116da493bc0a5e64328f49dfa28dabd525f508e430eba7ea1dc798a9269249cfad16611b9a05a3d55f2ffc1745a90e8f4a23
+EBUILD sybil-4.0.0.ebuild 670 BLAKE2B b8b98592b5dcdd276a84d48c195d359314c7be24c15e3ba38ae8659b2a0470865f37a536a50750ef7242801f18ddd0159ab08c16557cfebecd082b9befa8fafd SHA512 137ac0799f7e6f056c31ed9315e222e8678b6b25e3d941b139aff789493237ff9707846d3cd7037ab3322a2d57f03a65e1e6eb4cb089c63568f5db339fa8c2d6
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-4.0.0.ebuild b/dev-python/sybil/sybil-4.0.0.ebuild
new file mode 100644
index 000000000000..a54934b5878a
--- /dev/null
+++ b/dev-python/sybil/sybil-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest