summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-14 22:38:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-14 22:38:28 +0100
commit9f1c285c267548022db687a4fe85501b006d68b7 (patch)
treed358ae12d572c7af8aff34cfd78b49e8fb40943c /dev-python/sybil
parent3eb3ea9bc18adf028abfe51d11436c3777202f8c (diff)
gentoo auto-resync : 14:07:2023 - 22:38:28
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-5.0.3.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index ba7aff3b99e1..8f609adc7ee6 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-5.0.2.gh.tar.gz 56319 BLAKE2B 56c64c0110a7d0e808eaf786a22e8ce30572a8546be85987b4c26d86e1d8ea8c3f35557463a032a32b23861e7403a4196b03ab0b4d2641d6854f5d4cfd6d4b18 SHA512 43b8a7e6067d99a82e1ef07fce0a2034402db086f5a2043c0c4136eca8bf27a2e53d26f03d0e717b05076a5e65cfc259e685c883a7526840135454a6c68c3100
+DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
EBUILD sybil-5.0.2.ebuild 734 BLAKE2B c021f70cb3a198acdef44c2b3232c78adeccc7c73045a7298307069b78a706b9ce3b8f62868a4c1511bb0eaa6c2394333a5eef0f6e2ee7c967dcde433db4a391 SHA512 ba188b19f85b27df8a99e9edb34ac8f5f9a005e14a931c06dd92fe0ae7ca57552a17cea459816e33d942b3a837c0929e7df16f4f4b9a82dd809bc6d8722093c0
+EBUILD sybil-5.0.3.ebuild 737 BLAKE2B 39526ffc904a918d85d327bdb9a8cce6a3909982e506ff856b681dc5d34c68812a822c987fb9fa84bc13eb5b24f1c5fccc6960751bfa80851ac7c27c1ad7f943 SHA512 4cb9c09e843ec3d2828fa07e76740286f5e5f47cb845a70cc9a6b5fdaac9ffdebe2a14d04bf36a0bf0a5611c0d356604904771d21d40c2a244c7c833b5964b1c
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-5.0.3.ebuild b/dev-python/sybil/sybil-5.0.3.ebuild
new file mode 100644
index 000000000000..e18ec7aee855
--- /dev/null
+++ b/dev-python/sybil/sybil-5.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest