summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 11:17:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 11:17:57 +0000
commit77b74be093bdf4a0ed4121acc3f8e229103cf004 (patch)
tree63d35b3e7246dd3ae3c181b1e47212a89a5f8d2c /dev-python/sybil
parent734d2dac3e96161f025c33aa2d518d798cd06580 (diff)
gentoo auto-resync : 22:11:2023 - 11:17:57
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest4
-rw-r--r--dev-python/sybil/sybil-6.0.0.ebuild34
-rw-r--r--dev-python/sybil/sybil-6.0.1.ebuild34
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index d972211eaff8..13f6e201a479 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,7 @@
DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
+DIST sybil-6.0.0.gh.tar.gz 67505 BLAKE2B b7408802d5f6796701603762f1e48dbd2f218b5ae80fad940f1ba1fdf0643d1f16cb0a88d94b6385f6ff47d4ab18463be613f736613fa5f0baa3f9ff056ebfa8 SHA512 a03cb7e874a6a41f41ca21e9110f0b8f0d45bb94a5cd7c4f0eb0528ce01db4ac9ca6d8d84663d8851c01dda5da3cb232bcadb33594c5c10e5775f390db37ee9a
+DIST sybil-6.0.1.gh.tar.gz 67593 BLAKE2B 443881e81da6456f0790929556334513a8e50d54a0053ddb88b07e29e736e9429ea59fdc30b2d7ff7bdf7e1ec9e272864568aa64fb20a52377d0ee0b39ce30aa SHA512 e71f06744ff07f973ac7f131cd58d4df3697b1cf42a5983b9a93b657d9bfc9358084dcdec00de624b5e89ffa518e64d45591bf616fb53f5e4659ff9755893cd9
EBUILD sybil-5.0.3.ebuild 734 BLAKE2B 46ce10ce0cac76396586205f9a4abb001f265c0b3b03149e065fd023eefd102517057e2ed7dd7080e47648abda923518fc394de99d42a9df03cb848f99808be8 SHA512 690027da753a48fea77fae8bc519698cd75a2a6518d7c76cfbfad8b775dbaa28f4580c266b896f95d79734da452a2738ea63638d40d03c3f597a672910ffe37a
+EBUILD sybil-6.0.0.ebuild 737 BLAKE2B 7f93846c3b52dab2445c0faed07671010cd88479fe5206a6916754166f880491aaa545f329d8e58796c730504af2aaaba43969c563a56e05c774dcee4426c892 SHA512 604f04bbc04cd6f79817aaeade9794a36c3d35e3462e71ec4e09ff8ff36b6a8451b5676ef8f066533fc505b64f3701ce33d1e5b274002783d0aa293743420f25
+EBUILD sybil-6.0.1.ebuild 737 BLAKE2B 7f93846c3b52dab2445c0faed07671010cd88479fe5206a6916754166f880491aaa545f329d8e58796c730504af2aaaba43969c563a56e05c774dcee4426c892 SHA512 604f04bbc04cd6f79817aaeade9794a36c3d35e3462e71ec4e09ff8ff36b6a8451b5676ef8f066533fc505b64f3701ce33d1e5b274002783d0aa293743420f25
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-6.0.0.ebuild b/dev-python/sybil/sybil-6.0.0.ebuild
new file mode 100644
index 000000000000..38d5f40dd52e
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sybil/sybil-6.0.1.ebuild b/dev-python/sybil/sybil-6.0.1.ebuild
new file mode 100644
index 000000000000..38d5f40dd52e
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest