summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-13 12:31:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-13 12:31:46 +0100
commit6fcdccbe589d724b6c268b49f66414e40eb0d807 (patch)
treeb0b74ac37d41e5d22a5a758517b215d1829cdb67 /dev-python/sybil
parent3ea54510168a7ed4271b85f7292beca67346bfe9 (diff)
gentoo auto-resync : 13:09:2024 - 12:31:45
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-7.0.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 9acde38ae683..5ecf9e5ae72d 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
DIST sybil-6.1.1.gh.tar.gz 71447 BLAKE2B 44ced68adfae094454c9dc4ae55b7327fc9d149728ec9f2faafc42057bc9e99572289100e310f16afdde7741841964a365c008fc9a16092d270ce88dfb0d89be SHA512 f14bb09b8886bd17ccd3a56d3dfc8e2ff510ad04f7b9c8deadff826571e36547934af6855e0a6cbed43e0c0767a0f0af8f80afcecf4a8db74b041fae9d84bd5a
+DIST sybil-7.0.0.gh.tar.gz 74678 BLAKE2B 17ff70054211437c1b1d2053c6f3cea78ba6e401310853ce1b8397caf992267338a7f868b33174d5bbba1c54c1709bade7f4474a0bcb2e8a59e6e9a93e308574 SHA512 ebc0300d0d36abf6307f9104887eb5f9daa78fa9a86bb985b3fbeb05ffbf1ed8a682c681a207dcd1ee0cb37b8448567a50c19ca3657f391a58655253798665d4
EBUILD sybil-6.1.1.ebuild 835 BLAKE2B 439b13513fffa6b0ccf502c6cf058eee330e643e066d958766855e9255e69bdbe7542599dddbe1c4e53ff529180cdf0c6a0c984cb90a33ae5e7faf6a3d327c0a SHA512 313d334b0db7cbe4b68ee5d0efc9861859c3c26f7b707d18f22674c454e223617eef7541e02039f661ff4ae0f1a4a7370d804ac9fa60d20fece991a99460e9ea
+EBUILD sybil-7.0.0.ebuild 841 BLAKE2B ebcf1feb254b315659722656488d1e0ddd7d132158a71d2f9360e31a7e1a3236db1929e623f3cbb189ceb6e9160b7ff296051e7b965e535b58f9bfef1e519634 SHA512 058873c18d60230c281171d2312359ad4a58a6e91b4aac723a67b265ac67ba9cd53fe7d5524bfab9572b08db93b99aef5fe15feecebc15438501d26ae53d1d2b
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-7.0.0.ebuild b/dev-python/sybil/sybil-7.0.0.ebuild
new file mode 100644
index 000000000000..e8ed9cd20ff9
--- /dev/null
+++ b/dev-python/sybil/sybil-7.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}