summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/sybil
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest6
-rw-r--r--dev-python/sybil/sybil-1.2.2.ebuild22
-rw-r--r--dev-python/sybil/sybil-1.3.0.ebuild (renamed from dev-python/sybil/sybil-1.2.0.ebuild)9
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index b35b22f084b6..f973e7da6400 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,5 @@
-DIST sybil-1.2.0.tar.gz 28720 BLAKE2B fc2fda9763a33cf89f47b5edf3aacf1d3c9ba712cc6e292dce0549393f2177afb6ff058e6c4ac96b0ffcc44149dab4c8da5da50ef6850555e374ca25906b1e14 SHA512 9355bfe2873eb9cec866a1c267deb876f3e6b1e452e0b7c951e5ffb642e79cb6602bc81384ff4e5bfff1adc0be2c95bcfa291d34b7690feae9b280a92b6b5c85
-EBUILD sybil-1.2.0.ebuild 453 BLAKE2B bff7613bc1ff660fd94680211661aa05e42ad17beab8d7e5706ddab045201c4b66630b9e9bbd1fd1aaec65ca1b340b999bf7a27ab24c725236da122b5436dae1 SHA512 9e6695396cb4c9626e20daef8b46bbeeb54ca9f0d3d822f0498c1120042e9d549264ebf8d4d9aa2e2dbf134b1937b9ebf41ee7123de3f40bcab1a1e360d49703
+DIST sybil-1.2.2.tar.gz 29182 BLAKE2B d0d9a0a2e5117efd36e7561f74d31283fa25ea0210e0796fe1a1cc4247712bff0e3ac329781987b5ba805ccd2cddf01eec2672d5e2677422d1ed378068482da5 SHA512 c1785c00ce1dfdaf85d13db976f28062c09c47974107bc2af54c3bd9bf4ad5124c9b52321f3350fb1cc50aefdf72f2a9b6b22fc766b139516ff7979864604735
+DIST sybil-1.3.0.tar.gz 29296 BLAKE2B a7f08f6374e12213b644685276832eca849c85e85c8aaf0a37bdfdbf648e0e0e4c2b3d1a4dc7038c91fe8d64aa476d96bf87fa3a5f2f11a955b758182411763d SHA512 fc478896bb1958303ffcac6d35993b2785a50c6c221848d83c92c158a27fff059491aa3baaddd0b56e040fe6c07b764aa33c69204750de9ad351084b2815fd47
+EBUILD sybil-1.2.2.ebuild 547 BLAKE2B c5d6e1a4a1aea1ad6d572084929797e7dbf42e5cf38a449dbe45d275f26100b580845df89bc28a3d45e60c655cc993c95394cb6c98ac6be8e81c4ba882acb3dc SHA512 ebcf347f6db3014d8b4914dd1227edc5c9b61223156b5f133f3d92f561f76e089f9ee66d1e6cdfbfb8532a5155faad331237ffa1495220414169af0715a2345f
+EBUILD sybil-1.3.0.ebuild 548 BLAKE2B 0391a5c7a2d5f2149a422701acb8e832d3e06b8167bb1b6ae27942eb29ddff87d6d7f42aff31ee7348897d04d2d026d18c0e5a1db35829110219e04f87eb20ae SHA512 441f8ebc92a0a01c94da3b02f580be1b6f7b02f779183279fd8b653a35f44b72f8c9337fb359b668de2706f7f956668db55785e2d042e879e65dcce46fd7f2ad
MISC metadata.xml 372 BLAKE2B ee52c5344be6eac7a7a79165e71cf7d198d8ee21591c4bbe5b8ebfb830019aa9bd32cb4912e6aaa59ca9e2147262278f2bafa3b24a89fcb67e930ed2a033c281 SHA512 c586f579a99f202fc403523fa870bc7aa31a437527091c413abf4c47795671ebbb783c74afe32790e25c75c9aeb19dbd0e6dd7367cdcb69ebf128367502b86de
diff --git a/dev-python/sybil/sybil-1.2.2.ebuild b/dev-python/sybil/sybil-1.2.2.ebuild
new file mode 100644
index 000000000000..f6d552ae95c2
--- /dev/null
+++ b/dev-python/sybil/sybil-1.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="https://github.com/cjw296/sybil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+# nose is used to test nosetests integration
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/sybil/sybil-1.2.0.ebuild b/dev-python/sybil/sybil-1.3.0.ebuild
index a7c5878a24d6..3918a42c35cd 100644
--- a/dev-python/sybil/sybil-1.2.0.ebuild
+++ b/dev-python/sybil/sybil-1.3.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Automated testing for the examples in your documentation"
@@ -14,6 +15,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="${DEPEND}"
+# nose is used to test nosetests integration
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest