summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /dev-python/sybil
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest2
-rw-r--r--dev-python/sybil/sybil-5.0.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 7a998afc6500..413e5176e204 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,5 +1,7 @@
DIST sybil-4.0.0.gh.tar.gz 50845 BLAKE2B 5c7144ad1dd131f98c48f18cf6770782529a3c86a3f976461f032c9024ef93dc2de3c8bc327421a55a3f505982608e15cdcfe022f964c4fd871bd9de61205d68 SHA512 6cf0422ba856a85ba5dd105481cb2d06eb2ff196aee263a36e7ab44c7d45185df022bd859afc92b3b42dc418142e441f377adda82c0b5b0d1410697b563db994
DIST sybil-4.0.1.gh.tar.gz 51137 BLAKE2B f18a84a8ee6524c8af2a54ea17d50e04dba90be54bf5345061d2b6ee161de5c19cb8e1a1849f83401ac5a175453a927f2e068129ccaa4707a48509bb0dc73015 SHA512 70db2aae9f8503af8c5ecb65c5d63e928ba81bc7324473b056a6c1cbb4dac9674c34252665e7b28a1134c37190cdb2fd00c37633a68ea4ac61104a12ea744442
+DIST sybil-5.0.0.gh.tar.gz 55213 BLAKE2B c95c051ee1a2edf5f9be0cc1dc23caf4c48a6e6b29e16c5b1e9f1ab785012d774eed8f972467132ecad530d59f992dd802474178e32df0a47fcfed36192689de SHA512 6511ad1ba6c814d0ab951f96e2ea7e4791fac3fbcae47693e8562fafe8e0c73648407e10036ebed42ac4ebb1458208677d850f46dbe238419f7ae545f8add6b6
EBUILD sybil-4.0.0.ebuild 691 BLAKE2B 34f8a0aa568e148eb6709be3ceabfac4e4d974d9dbfc961ee4d13c8f126ce1aeb5d5453b82ee19c02b7411fffb27ba5dcfea2cfe0224d3646f180e8d8bc34815 SHA512 8b02f6a38c5b4281eabaa5a95e5376770e1629c1ee3c200770e8e7c8628f454ffbab741f343e3330eff0f3237f6a2647f798f6485581dbd50182de41eb0639bf
EBUILD sybil-4.0.1.ebuild 694 BLAKE2B 8e3def3eb0ae205ed8a00051cd3f4131695178669eaf26e670a2f7cb0169c5e3a467d69d12a225582888e4ee87d0f70ec4015513daba4fd7f17b7b02c7f53683 SHA512 229c49576333132dfa21ca05f93adbd8bbc837c60e53c021db67eb7232a2866305fae4c40990bb33f5072eb7c61b2453a0e7d8332a5b995ede0459a6657b7839
+EBUILD sybil-5.0.0.ebuild 694 BLAKE2B 8e3def3eb0ae205ed8a00051cd3f4131695178669eaf26e670a2f7cb0169c5e3a467d69d12a225582888e4ee87d0f70ec4015513daba4fd7f17b7b02c7f53683 SHA512 229c49576333132dfa21ca05f93adbd8bbc837c60e53c021db67eb7232a2866305fae4c40990bb33f5072eb7c61b2453a0e7d8332a5b995ede0459a6657b7839
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/sybil-5.0.0.ebuild b/dev-python/sybil/sybil-5.0.0.ebuild
new file mode 100644
index 000000000000..930ce7413c4e
--- /dev/null
+++ b/dev-python/sybil/sybil-5.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest