summaryrefslogtreecommitdiff
path: root/dev-python/svgwrite/svgwrite-1.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/svgwrite/svgwrite-1.1.12.ebuild
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/svgwrite/svgwrite-1.1.12.ebuild')
-rw-r--r--dev-python/svgwrite/svgwrite-1.1.12.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.1.12.ebuild b/dev-python/svgwrite/svgwrite-1.1.12.ebuild
new file mode 100644
index 000000000000..dde90e114ee0
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.1.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"