summaryrefslogtreecommitdiff
path: root/dev-python/svg-path/svg-path-4.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/svg-path/svg-path-4.0.2.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/svg-path/svg-path-4.0.2.ebuild')
-rw-r--r--dev-python/svg-path/svg-path-4.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/svg-path/svg-path-4.0.2.ebuild b/dev-python/svg-path/svg-path-4.0.2.ebuild
new file mode 100644
index 000000000000..e9e4587533bb
--- /dev/null
+++ b/dev-python/svg-path/svg-path-4.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="svg.path"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SVG path objects and parser"
+HOMEPAGE="https://github.com/regebro/svg.path"
+SRC_URI="https://github.com/regebro/svg.path/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install() {
+ python_domodule src/svg
+}