summaryrefslogtreecommitdiff
path: root/dev-python/sure/sure-1.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/sure/sure-1.2.5-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sure/sure-1.2.5-r1.ebuild')
-rw-r--r--dev-python/sure/sure-1.2.5-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/sure/sure-1.2.5-r1.ebuild b/dev-python/sure/sure-1.2.5-r1.ebuild
deleted file mode 100644
index fa76a8a27c7e..000000000000
--- a/dev-python/sure/sure-1.2.5-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Utility belt for automated testing in python for python"
-HOMEPAGE="https://github.com/gabrielfalcao/sure"
-SRC_URI="https://github.com/gabrielfalcao/${PN}/archive/${PV}.tar.gz -> ${P}-r1.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND="
- >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
- ~dev-python/rednose-0.4.1[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${CDEPEND} )
-"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}/${P}-r1"
-
-python_prepare_all() {
- sed \
- -e "82s/read_version()/'${PV}'/" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -s tests --rednose || die "Tests failed under ${EPYTHON}"
-}