summaryrefslogtreecommitdiff
path: root/dev-python/sunpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sunpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sunpy')
-rw-r--r--dev-python/sunpy/Manifest3
-rw-r--r--dev-python/sunpy/metadata.xml18
-rw-r--r--dev-python/sunpy/sunpy-0.8.0.ebuild51
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/sunpy/Manifest b/dev-python/sunpy/Manifest
new file mode 100644
index 000000000000..52429a42b3c9
--- /dev/null
+++ b/dev-python/sunpy/Manifest
@@ -0,0 +1,3 @@
+DIST sunpy-0.8.0.tar.gz 6336169 BLAKE2B 554e64c27bb2c9c68629401bef83da3248a841c728d040fbda77465f04bd2c6a2cfb48f3a5df2bb0b15a306d6664f635aac7342e1135cf3bc61e1436a4db934a SHA512 7996fdcb47e4143159253180b2250ea7ac4aa8fecf8d3f1eae930da018d39ce4e663c843b4b0532e900f97d2bc9fadfd7c17837f4f045634820059a5af802eda
+EBUILD sunpy-0.8.0.ebuild 1418 BLAKE2B 9d091c41e5a78713f4ad9c1492e9b1bdea9630e57c034bc3e9f9bdd2397fdaaf4c8d450a28e5ea1d544d8b90296ab9bec91d17108dfba88f401aeb1091df2c76 SHA512 55b878b6b781450079f921c183346d955767e15a27c8dfee7f736a9d3c0971c1e01e2b2609094e4d054f8026c876304b53fea7ad0314fb8a99fc7ed433c1fcc2
+MISC metadata.xml 746 BLAKE2B 6e29c441458f02b55f3daffb617f9fb6d6df165999ca690403a3e563448e21a08a3648dbf110c25f29f4590b4831593c9404277471c89d716ddc9c8f03781a51 SHA512 73242a446a71a5f670e1993dd20ed2a66f06a3f3751e351edd9f24a2e77989f0aafde489b348d51264c0e4b1eca5fe34552b7378dc0bd19a8c351294adeb2b26
diff --git a/dev-python/sunpy/metadata.xml b/dev-python/sunpy/metadata.xml
new file mode 100644
index 000000000000..1915944eec82
--- /dev/null
+++ b/dev-python/sunpy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ SunPy is a community-developed free and open-source software package for
+ solar physics. SunPy is meant to be a free alternative to the SolarSoft data
+ analysis environment. The aim of the SunPy project is to provide the
+ software tools necessary so that anyone can analyze solar data.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sunpy</remote-id>
+ <remote-id type="github">sunpy/sunpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
new file mode 100644
index 000000000000..4aa502509e14
--- /dev/null
+++ b/dev-python/sunpy/sunpy-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Software library for solar physics based on Python"
+HOMEPAGE="http://sunpy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="jpeg2k test"
+
+RDEPEND="
+ >=dev-python/astropy-2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
+}