summaryrefslogtreecommitdiff
path: root/dev-python/sunpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
commit30c53e395853f5bfe805a1e429fcf26666eed8f8 (patch)
treea0670eaf9babda7b83503f7d36806a944bb49752 /dev-python/sunpy
parentd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (diff)
gentoo resync : 17.05.2018
Diffstat (limited to 'dev-python/sunpy')
-rw-r--r--dev-python/sunpy/Manifest2
-rw-r--r--dev-python/sunpy/sunpy-0.7.9.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/sunpy/Manifest b/dev-python/sunpy/Manifest
index 941b09513d0b..52429a42b3c9 100644
--- a/dev-python/sunpy/Manifest
+++ b/dev-python/sunpy/Manifest
@@ -1,5 +1,3 @@
-DIST sunpy-0.7.9.tar.gz 5690849 BLAKE2B be4178d603eb7b65346b46fb75627a1d177f7c9e93cbd16409ddddc3d46ef814303b0f701c331e198b430243baa8fafc54f77524666e0383ec5097d6ca3e5b52 SHA512 e8322ecf7c797a377fd8ff6962d6d66e147ba893a58e8abbbfa1dad6a391eecc161846a51fba3c92e90a3709125d759da76d444ca3f4ff0878768d23da1f41a3
DIST sunpy-0.8.0.tar.gz 6336169 BLAKE2B 554e64c27bb2c9c68629401bef83da3248a841c728d040fbda77465f04bd2c6a2cfb48f3a5df2bb0b15a306d6664f635aac7342e1135cf3bc61e1436a4db934a SHA512 7996fdcb47e4143159253180b2250ea7ac4aa8fecf8d3f1eae930da018d39ce4e663c843b4b0532e900f97d2bc9fadfd7c17837f4f045634820059a5af802eda
-EBUILD sunpy-0.7.9.ebuild 1384 BLAKE2B b68d52d9640ab46b0d48cf5a03621a4ecb04506965f1890ecbecfe392cd643c38a1da59046db8c4cd7a7dcc54fd25c495b3245639cee398e2f9548f1e20c317d SHA512 86fe8035ffd52450d4d0b4ccccffa4b41fdceeb7d62eee7a2e9bc79626a7b0260018ca92f93dd5cd18b78d6515825864bcd55c43c45e258caf68ce86d3b02209
EBUILD sunpy-0.8.0.ebuild 1418 BLAKE2B 9d091c41e5a78713f4ad9c1492e9b1bdea9630e57c034bc3e9f9bdd2397fdaaf4c8d450a28e5ea1d544d8b90296ab9bec91d17108dfba88f401aeb1091df2c76 SHA512 55b878b6b781450079f921c183346d955767e15a27c8dfee7f736a9d3c0971c1e01e2b2609094e4d054f8026c876304b53fea7ad0314fb8a99fc7ed433c1fcc2
MISC metadata.xml 746 BLAKE2B 6e29c441458f02b55f3daffb617f9fb6d6df165999ca690403a3e563448e21a08a3648dbf110c25f29f4590b4831593c9404277471c89d716ddc9c8f03781a51 SHA512 73242a446a71a5f670e1993dd20ed2a66f06a3f3751e351edd9f24a2e77989f0aafde489b348d51264c0e4b1eca5fe34552b7378dc0bd19a8c351294adeb2b26
diff --git a/dev-python/sunpy/sunpy-0.7.9.ebuild b/dev-python/sunpy/sunpy-0.7.9.ebuild
deleted file mode 100644
index 9d1336d23d42..000000000000
--- a/dev-python/sunpy/sunpy-0.7.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Software library for solar physics based on Python"
-HOMEPAGE="http://sunpy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="jpeg2k test"
-
-RDEPEND="
- <dev-python/astropy-2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/suds[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_image[${PYTHON_USEDEP}]
- jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mpl[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # use system astropy-helpers instead of bundled one
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
-}