summaryrefslogtreecommitdiff
path: root/dev-python/sunpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/sunpy
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/sunpy')
-rw-r--r--dev-python/sunpy/Manifest3
-rw-r--r--dev-python/sunpy/metadata.xml18
-rw-r--r--dev-python/sunpy/sunpy-0.8.0.ebuild52
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/sunpy/Manifest b/dev-python/sunpy/Manifest
deleted file mode 100644
index 692fe5c542b8..000000000000
--- a/dev-python/sunpy/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST sunpy-0.8.0.tar.gz 6336169 BLAKE2B 554e64c27bb2c9c68629401bef83da3248a841c728d040fbda77465f04bd2c6a2cfb48f3a5df2bb0b15a306d6664f635aac7342e1135cf3bc61e1436a4db934a SHA512 7996fdcb47e4143159253180b2250ea7ac4aa8fecf8d3f1eae930da018d39ce4e663c843b4b0532e900f97d2bc9fadfd7c17837f4f045634820059a5af802eda
-EBUILD sunpy-0.8.0.ebuild 1441 BLAKE2B 60f98cb154d058ea595862f847c457febd41f6fecc3d83324d497aa95c9d602566f87d198d40f205d1997ed04d003b6cb341b551101ca624a24217d154ad8a73 SHA512 8d6ca9d683aeb87f49f3c7fbfa5c6412d0e0aba8147a49c1e260d4266e774f825d305b76989157220c01e666b52d13a58cbbd3ec46be17d56c01e480c287bc1b
-MISC metadata.xml 746 BLAKE2B 6e29c441458f02b55f3daffb617f9fb6d6df165999ca690403a3e563448e21a08a3648dbf110c25f29f4590b4831593c9404277471c89d716ddc9c8f03781a51 SHA512 73242a446a71a5f670e1993dd20ed2a66f06a3f3751e351edd9f24a2e77989f0aafde489b348d51264c0e4b1eca5fe34552b7378dc0bd19a8c351294adeb2b26
diff --git a/dev-python/sunpy/metadata.xml b/dev-python/sunpy/metadata.xml
deleted file mode 100644
index 1915944eec82..000000000000
--- a/dev-python/sunpy/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-astronomy@gentoo.org</email>
- <name>Gentoo Astronomy Project</name>
- </maintainer>
- <longdescription lang="en">
- SunPy is a community-developed free and open-source software package for
- solar physics. SunPy is meant to be a free alternative to the SolarSoft data
- analysis environment. The aim of the SunPy project is to provide the
- software tools necessary so that anyone can analyze solar data.
- </longdescription>
- <upstream>
- <remote-id type="pypi">sunpy</remote-id>
- <remote-id type="github">sunpy/sunpy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
deleted file mode 100644
index c0c051c1581d..000000000000
--- a/dev-python/sunpy/sunpy-0.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Software library for solar physics based on Python"
-HOMEPAGE="https://sunpy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="jpeg2k test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/astropy-2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/suds[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_image[${PYTHON_USEDEP}]
- jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-mpl[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # use system astropy-helpers instead of bundled one
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
-}