summaryrefslogtreecommitdiff
path: root/dev-python/suds-community
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/suds-community
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/suds-community')
-rw-r--r--dev-python/suds-community/Manifest5
-rw-r--r--dev-python/suds-community/metadata.xml15
-rw-r--r--dev-python/suds-community/suds-community-1.1.0.ebuild22
-rw-r--r--dev-python/suds-community/suds-community-1.1.1.ebuild31
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/suds-community/Manifest b/dev-python/suds-community/Manifest
new file mode 100644
index 000000000000..b35a1e7195b3
--- /dev/null
+++ b/dev-python/suds-community/Manifest
@@ -0,0 +1,5 @@
+DIST suds-community-1.1.0.tar.gz 284545 BLAKE2B b5f6f6f46a35df3263664c9893745a2e723f3eef543cb1a9e9fd061956b0c00c219e818228de9bf11b2730ad0a8fed90ad731199ffc7ca9fba9f22c5c0c8dd41 SHA512 2c8902e16c3513c99ce6d8bdf58ef4f5c4d704f1bf2480ea2b23ec2adbd9e8919928bfd5e3fd6859028b7fbc3788d067b9b71bad2a20c2f4907e6e56f3f15350
+DIST suds-community-1.1.1.tar.gz 284934 BLAKE2B 9df1a5f6b4dd2ca060c639147a090cef6a194f275706e03a3fdafa46c4d18b890f7c94249db8db6202e95abea71948e0c42fe42f14f659ca14bb0aca11b4b5f5 SHA512 9b343d704b2db123ff44685fb03da8f6912cefb32d38e9b79f9f84aeebff32ba26936a0f70a6121628c6f2c5388e94d380f08ed546f55fbf84fdc8e4fdbd3d0a
+EBUILD suds-community-1.1.0.ebuild 504 BLAKE2B b7e6b2fc3a582e811327946133cf6dcd9d08af4cc9f0b558c2d9463fb630b59b817a629348e591b88867a16ed737d128a92d4ea40ab28d3e26bf58bbcb4d316d SHA512 3b37365768eaadbcfaf566bf4575002e766d8693221878e566d55cebd150b38ca6646de319b2f8c1cb4f105992bb3954a6d2ae54e4da0324e608c3ca2388fdb0
+EBUILD suds-community-1.1.1.ebuild 612 BLAKE2B f8a0ab7825954557ca1bdea42d7479ce65217044010992ef94e34337906513b5f64bc137a82c8ffc0d033ece8d4c886bfee4ef41e05e7b02a238a07333974024 SHA512 81fc06d415a6ee1e4d7791268b0636a37cd9d7a7e3b91b777afe045316d6a3c15c169585feee4e26d41267e55b241c2020a99aa32ca7ef75c5999772806b6245
+MISC metadata.xml 557 BLAKE2B 1ae35931a85cfdaf853e47471764926aaf69ecac0e4d0fb208278dbe2324bfb141d1f3a870eccb94fa10c4450c2c7a141a4c007cd24d65f51a52536f7b9839e4 SHA512 232676d84079a770034e67f6d23592375998b5940a46efb7f1a654de6a78df8296a3fef694e65a7767add3dcf3ccf0b0d947d0733c85a68f5c4ff802e09b0bec
diff --git a/dev-python/suds-community/metadata.xml b/dev-python/suds-community/metadata.xml
new file mode 100644
index 000000000000..95e66f156d62
--- /dev/null
+++ b/dev-python/suds-community/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">suds-community</remote-id>
+ <remote-id type="github">suds-community/suds</remote-id>
+ <bugs-to>https://github.com/suds-community/suds/issues</bugs-to>
+ <changelog>https://github.com/suds-community/suds/blob/master/CHANGELOG.md</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/suds-community/suds-community-1.1.0.ebuild b/dev-python/suds-community/suds-community-1.1.0.ebuild
new file mode 100644
index 000000000000..28052a8d1ecc
--- /dev/null
+++ b/dev-python/suds-community/suds-community-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="https://github.com/suds-community/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.md notes/. )
+
+distutils_enable_tests pytest
diff --git a/dev-python/suds-community/suds-community-1.1.1.ebuild b/dev-python/suds-community/suds-community-1.1.1.ebuild
new file mode 100644
index 000000000000..5edb87033f52
--- /dev/null
+++ b/dev-python/suds-community/suds-community-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="
+ https://github.com/suds-community/suds/
+ https://pypi.org/project/suds-community/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.md notes/. )
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest